Data Backup and Recovery

Failed to get Data ONTAP version running on the storage system


Hi guys,

We've got a SnapMirror issue for 3 weeks. Before that, everthing worked fine.

Here is the error log : 

[19:22:33.187]  Requesting SnapMirror update for LUN [C:\DB\LUN] on volume [LUN Exchange] of filer SAN02...
[19:26:03.935]  [SnapDrive Error]:Failed to get Data ONTAP version running on the storage system sqpsan02.
Error Description: RPC Error - Access is denied.
(SnapDrive Error Code: 0xc0040321)
[19:26:03.935]  [SnapDrive Error]:Failed to get Data ONTAP version running on the storage system SANMirror02.
Error Description: RPC Error - Access is denied.

Anybody has an idea about this issue ?

Thanks in advance.



It means that SDW is not able to authenticate to the storage system over the RPC protocol.

Is the storage system in the same domain?

You could also check this by changing the transport protocol settings to HTTP

Sdcli transport_protocol set


Yes, the storage system is in the same domain.

The thing I find weird is that no changes were made for one month. So, I dont understand why suddenly, there is a authentication issue.

Is that error can be related to DNS issue, or switch misconfiguration ?

So, I'm gonna try changing the transport protocol setting, as you advised.

Thanks for your answer.


If it is on the same domain, then it means that the user with which SDW service is registered is not able to authenticate.

Are both SMSQL and SDW registered with the same service credentials?


Yes, sounds like SDW authentication issue. I just had it myself 20 mins ago.

I would run compmgmt.msc on Windows side, go to Action menu, Connect to another computer, enter storage name, System Tools, Groups, double click Administrators, and make sure that the local (server) admin account you've chosen (to start SnapDrive service) is listed there in "DOMAIN\username" format. If not click Add to add the account. It worked in my case.




Thank you all for your answers.

I juste solved the problem, it was due to bad credentials defined on the disant SAN. I changed it back and everything's just fine now.

Hi Can you tell me how you solved this please, getting the same issue. Thanks!

I just changed the Snapdrive's Credentials on my Exchange Server. (In the services, Log On as)

The credentials were changed by the SMBR I think.

I hope that will help you to solve your issue.



The time on the filer was off by more than 5 minutes when I saw this issue.  I am sure you resolved this issue by now but for other users it may be helpful.  -Frank.