Data Backup and Recovery

NetApp Data Broker 1.1 and SnapCenter for vSphere - Backups not Deleting

cchandlervmware
1,593 Views

We have a policy configured to delete our backup images after 7 days. The policy is not deleting the older backups causing our volumes to fill up with unexpired backups. We are running vSphere 6.7 Update 3. 

 

Thanks - Chris

2 REPLIES 2

sesanshu
1,517 Views

Are you referring NetApp Data Broker 1.0.1  or 1.1 ?

 

 

gherardini
780 Views

I am having this same issue, Data Broker 1.0.1, vCenter 6.7U3m. 

My issue started when I added a second Policy for a shorter retention period (35 days vs 42 days) and edited each of our Resource groups to use the new, shorter retention policy. Maybe it will only address its own 35 days and will begin to delete snapshots outside of the retention period?

The only way that I've had this succeed is to suspend the current Resource Groups, create new Resource Groups using the new Policy, and let the new RG reach its retention period and begin to delete its own, outdated snapshots. This requires a manual deletion of the older snapshots from the original RG so that the volume won't fill up. If you simply delete the original RG (instead of suspending) before creating the new one, you will lose ALL your snapshots from that RG (can you fix that?? maybe with a selection to "Do you wish to delete all your current snapshots associated with this RG? --No, I don't). I learned THAT lesson one day....

But currently I still have the issue that if i edit the RG with a new policy, my retention policy is not propagating the the previous policy's snapshots. Still waiting to see if the new Policy will get to deleting its own snapshots w=once they are aged over 36 days...

thx

Public