Data Backup and Recovery

SMBR Crashes after hashing EX2010 DB



I'm trying a restore of an users mailbox with SMBR. I've user SMBR before, but this is the first time I tried a restore of an Exchange 2010 DAG Database...

When it is finished hashing the Database and scanned the Log directory it stops working and Windows detects an "appcrash"

Finally it closes...

We have got 2 Exchange Servers in an DAG cluster config.

Software specs:

- Exchange 2010 Sp1 on Windows 2008 R2 EE x64

- SnapDrive 6.2P1 x64

- SnapManager for Exchange x64


I tried SMBR on several servers and none can perform a restore, checking the DB with Eseutil.exe learns that it is in a "clean shutdown" state.

Does anybody has experience with this kind of restore, or has someone an idea how to resolve this?

Thanks in advance.




It seems to be a limit when a number of records reach a certain point in DB due to exchlib.dll.

Open a case and ask for this dll at a first stop.



Is there a solution for this?

I have a customer with the same issue. I have a open case with  NetApp support, but no response yet


We are still waiting for the correct DLL, but we created the case on a serialnumber which hasn't got support anymore...

We had to use a workaround, restored the entire EDB and used the Exchange recovery groups.



Okay, then I will ask our customer to do the same.

Then let's hope that the new DLL file will be released in near future.

Best Regards

Bo Sorensen



I got a new DLL file, and we can now open a 230gigs database in SMBR.

By the end of January (If they don't find any issues) there will be relased a new version of SMBR where this is fixed.


I just got off the phone with Netapp support and upgrading to the SMR 6.0.2 version will fix this issue. The upgrade can be found here:

The problem is because SMR cannot open volumes larger than 100GB. The update will allow for larger volumes.