Data Backup and Recovery

SMO start clone in archivelog mode




Has anybody been able to successfully create a clone of a DB that starts in archivelog mode by editing/creating a clonspec.xml file to include the following parameter:




For some strange reason, even though the fore-mentioned entry exists in the clonespec.xml file that I load in it at the start of the process. When I go to the parameters section it does not display. Needless to say it is not applied and therefore starts in noarchivelog mode.


The other option I have is to add a parameter entry manually from the GUI, but even this does not work.


Looked around on Burtweb (as it looks suspiciously like one) but cannot find anything related.


Anybody got any ideas?


Environment is W2K3/iSCSI/3.0.2




Have u tried using the log_archive_dest_n parameter?  Plz check the following info in the SMO 3.0.2 IAG:

Specify any Oracle parameters that should be set to a different value in the cloned database than in the source database. If you are using Oracle 9 or 10, you must specify the first three parameters.

  • Background dump
  • Core dump
  • User dump
  • (Optional) Archive logs

If you do not specify archive logs for the destination, SnapManager creates the clone in NOARCHIVELOG mode. SnapManager copies this parameter information into the clone’s init.ora file.

Note: If a parameter entered conflicts with a parameter that SnapManager for Oracle must change to create the clone, the clone operation is aborted and you receive an error message.


The following example displays the parameter syntax to use in the clone specification.


Also are u using the enterprise edition of Oracle in which case the LOG_ARCHIVE_DEST param might be deprecated.  Check the following link:


Yes, I have tried setting that parameter thanks. From within windows it just does not seem to work from the GUI whem you load a clonespec.xml and then edit.

If I use the command line it works fine, a possible BURT?