Data Backup and Recovery

SMSP 7 Content Database Backup Fails.



I have a very annoying problem.

The issue is this:

I have a SMSP 7 environment, and a SMSQL 7 environment where the SQL DB's reside. When I run a backup from the SMSP server, it completes with exception. When I check the log, it fails on all the Content Databases. Everything else runs through 100%

But the strange thing is when I check the SMSQL log, the backup completed OK for those DB's

I do not know that to do now, I upgraded everything, ie Snapdrive and all the Snapmanagers to the latest versions, but I can't get this resolved. Below I will post the logs from both systems.

I know the storage policy and logical devices work, because it is getting populated by all the sucessfully backed up data.



Hello Christopher,

It looks like you are making streaming backups of your SQL databases instead of snapshot backups. This can happen when the sql system databases are on the same LUN as the sql user databases. This is not supported for SMSP. Please make sure you separate the SQL user and sql system databases and place them on different LUNS. See also

Good luck,


[OLKAS0068V2] Full database backup location for database [WSS_Content_Documents]:

[OLKAS0068V2] S:\SMSQL_SnapInfo\SQL__OLKAS0068V2\DB__WSS_Content_Documents\FG__\StreamFullBackup\01-18-2014_09.18.10__WSS_Content_Documents.FBK

[OLKAS0068V2] Connecting to SQL Server OLKAS0068V2...

[OLKAS0068V2] Starting full database backup for database [WSS_Content_Documents]...

[OLKAS0068V2] Database [OLKAS0068V2:WSS_Content_Documents] Percent: 5 percent processed.5[System.String]

[09:18:12.1361886]: [OLKAS0068V2] Database [OLKAS0068V2:WSS_Content_Documents] Percent: 10 percent processed.10

[OLKAS0068V2] Database [OLKAS0068V2:WSS_Content_Documents] Percent: 16 percent processed.16

[OLKAS0068V2] Database [OLKAS0068V2:WSS_Content_Documents] Percent: 20 percent processed.20

[OLKAS0068V2] Database [OLKAS0068V2:WSS_Content_Documents] Percent: 25 percent processed.25



I moved the system databases to their own LUN's However, I have the same issue. I am now  going to create a CIFS type storage profile, and see what the result is.


I am not sure if I am missing a step here in performing backups or maybe I misunderstand something....

I configured a CIFS type logical device. I ran a backup again. In the CIFS environment I get the same issue. Backup completes with exception. I want to perform file level restores after a full backup, but are unable to do so.

The snapshot backup on the SMSQL server goes through without a hitch, but in SMSP I get an exception error.

I attached a screenshot.....