Data Backup and Recovery

SMSP Database Migration


Hi there,

I've got a Problem.

In november we moved our server system locally. For that we have to shutdown the sharepoint sever (virtual).

When we restart all the systems the sharepoint sever have lost the LUNs where the database originally was set.

We attached them again and try to open the teamsites. Doesn't work. It turns out, that the database was now on the local disk and the necessary rights where missing.

We add the rights again. Now the teamsites works.

At least I've tried to migrate the database back to the LUNs. That doesn't works.

I can connect the SQL, but when I tried to associate the Database with the available Disks following failure appers:

Cannot export the config xml. Please check your SMSQL configuration and try again.

So I've tried to reconfigure the connection in the SnapManager for SQL Server. When I've  tried to open the database this failure appears:

Failed to connect to SQL Server "...". Verify the log-in credentials.

You may only perform restore operation. Please start the SQL Server you are connectiong to, and SnapManager will also try to start SQL Server during restore if it's stopped.

Details: Error Code: 0xC0040804 Faild to connect to the specified SQL Server.

The SQL Server is startet. The connection is made by windows login, exactly how i configured it, by installing Sharepoint the first time.

So I've go on with trying to reconfigure it with the Configuration Wizard. An other failure appears when the database selection should be done:

Faild to load configuration data. Details:[SQL-DMO API Error]:

Source: Microsoft SQL-DMO (ODBC SQLState: 42000)

Error Message: Unkonwn Error 0x800400E5

Description: Die EXECUTE-Berechtigung wurde für das 'xp_instance_regenumvalues'-Objekt, 'mssqlsystemresource'-Datenbank, 'sys'-Schema, verweigert.

(The EXECUTE permission was denied on the object 'xp_instance_regenumvalues', database 'mssqlsystemresource', schema 'sys'.)

Now I run out of Ideas. I've checked the Database permissions, but can't find a mistake.

Systems we use:


MS Sharepoint Foundation 2010

MS SQL Server 2008

NetApp SnapManager for SQL Server Management

NetApp SMSP Agent Tools & Manager Tools

NetApp SnapDrive

Thanks for any suggestions.




in the meantime do you have resolve your problem? If so please let know. I've nearly the same problem during fresh installation of SMSQL.

SMSQL cannot enumerate the lun where the databases resides.



When you installed SnapManager for SQL, you had to specify a service account.  That service account needs to be added to SQL Server 2008 with the sysadmin role.  In previous versions of SQL Server, it was enough that the account was in the local Administrators group, but this is no longer the case.

Note that this can be confusing when running SMSQL the first time because it asks you how to login and you probably told it to use the Windows Credentials of the current login user.  Therefore, you're probably suspecting this account is having permissions problems, when actually it is the service account that is having problems.   In fact, if you run a SQL trace on your server and specify to monitor for Login Failures, you'll see the login failure of this account.


Do you have more than one instance of SQL Server installed? Does the service account have sysadmin on all instances?

I ran into the same problem configuring SnapManager for Sharepoint. I installed a fresh SQL Server and configured SMSQL and handed over to app admin, who installed a SQL Express with the Sharepoint installation. Since my service account didn't have access to this instance, I couldn't run the SMSQL config wizard (gave me the same error). It took me a while figuring it out! Uninstalled the Express installation and voilá!