Data Backup and Recovery

SMSQL 5.1 verification (SDAPI error)

dailyfresh
3,259 Views

Hello,

We are using SnapManager for SQL Server 5.1 on a Windows 2003 Std. server with MS SQL 2005 std. Local backups and secondairy backups are fine. They are created and snapvaulted. But the status in the 'Restore' section of SMSQL had an orange qestionmark instead of a green check.

Reading through the backup logs I found that backup verification didn't go okay:

[11:59:30.946]  Using default mount point directory [C:\Program Files\NetApp\SnapManager for SQL Server\SnapMgrMountPoint]

[11:59:30.946]  Ready to mount snapshot from SnapVault secondary...

[11:59:30.946]  Preparing to mount snapshot 'sqlsnap__xxxxxxxx_03-08-2011_11.55.37__daily' of LUN 'E:\'...

[11:59:30.946]  Targeting to path 'C:\Program Files\NetApp\SnapManager for SQL Server\SnapMgrMountPoint\MPDisk001'...

[11:59:30.946]  Mounting snapshot using Dataset [SnapMgr_SQLServer_xxxxxxxx] with Backup Version [1299581752] and Backup ID [577]...

[11:59:58.711]  SDDatasetBackupConnect failed.

[11:59:58.711]  [SDAPI Error]: Failed to get Data ONTAP version running on the storage system filer02. Error Description: RPC Error - The RPC server is unavailable.

I've read the admin manual and searched the Internet, but I can't find an explanation or solution for the SDAPI Error.

We also use SnapManager for Exchange - on a different server - and those backups are all going okay.

Anyone a clue?


4 REPLIES 4

dailyfresh
3,259 Views

To be complete, an addition from the log which comes after the lines I posted before:

102

[11:59:58.711]  Unable to mount snapshot from dataset.

[11:59:58.711]  [SDAPI Error]: Failed to get Data ONTAP version running on the storage system filer02. Error Description: RPC Error - The RPC server is unavailable.


102

[11:59:58.711]  Error Code: 0xc004095c  Unable to mount snapshot using data set.

[11:59:58.711]  Database verification information was not updated.

[11:59:58.711]  There is an error during database verification.

abhisek
3,259 Views

Can you provide some more detailed info about the environment and when you are getting the mountpoint snapshot error?

Regards,

Abhishek

dailyfresh
3,259 Views

Already solved it. The backup filer resides in a different subnet. The route to this subnet was gone missing. I added the route again and the message changed to "RPC - access denied". Probably because a problem with a reverse DNS entry. Look into that later on. I switched to HTTPS and the message changed to "missing initiator".

So, I added an initiator session within SnapDrive and now it all works flawlesly.

abhisek
3,259 Views

Thanks for the update.

Regards,

Abhishek

Public