Data Backup and Recovery

Snap Creator 4.1.1: SCF-00019:SnapVault relationship not found on ONTAP 8.3


When trying to run a snapshot with snapvault update between 2 ONTAP 8.3 controllers i get the following:


[2015-01-21 14:40:37,389] ERROR: SCF-00019: SnapVault relationship for [pan-svm-kit01]:[cmsdbtest01_log1] does not exist, Exiting!


But I am sure this relationship exists, I can see it with a snapmirror show on the vault controller.


I got it to work fine with 7-mode controllers and using the MANAGEMENT_INTERFACES and SECONDARY_INTERFACES variables in global.conf, but these new controllers have totally consistant names, so it is not a problem.

Debug log attached.


Brgds. Martin





Please be sure that the controller name in the config file matches EXACTLY with what ONTAP has.


This has caused some issues in the past, so we are updating the Snap Creator IAG to include the below.

Maybe this will help.






Ah, error was found with a long trip to netapp support. CMODE=Y was required. (Doh!).


Now I cant get it to complete the backup as nothing seems to be able to delete snapshots from a snapvault volume on clustered ontap 8.3.




Do you have a case opened on this by chance?


Our QA team checked and verified that SnapVault deletion/retention is working properly with ONTAP 8.3.






Yes, I did create a ticket for it - I got it solved but it was eseentially just a very confusing error message.


It said Java Null Pointer Error!


But it was actually because I had configured a policy object without a snapvault policy, so it tried to do snapvault, because I had it configured to snapvault_update=yes, but the policy object was only LOCAL, not SNAPVAULT.

When I used a policy object with a SNAPVAULT type, then it ran perfectly.



Bottom line, use CMODE=Y and correct policy object, then its all good.


I do wish that was in a the manuals, there may be a description of all the parameters, but no guides to how to configure for example a configuration with snapshot and snapvault on a clustered ontap 8.3 filer.


Much wiser and with best regards,





It sounds like you had a couple issues, and we're trying to figure out how to improve the docs in this area.


Can you give us more details on what you were trying to do when you encountered this issue?


Did you have an existing config that you were adding SnapVault to?

Were you creating a new config, not using the GUI?

Or did you use the configuration wizard to create a new config?


Details on how you are trying to achieve these tasks will help.