Data Backup and Recovery

Snap Creator 4.1.2 + vibe Backup & restore problems (can't restore vm)



I have vSphere 6.0 infrastructure & Snap Creator 4.1.2 + cDOT 8.3.1 storage.

Snap Creator server is installed on stand-alone server (windows 2k8, not vcenter server), agent is installed on another windows server.

SC is configured with configuration for netapp (svm login), vcenter server and one test datastore is selected for backup (testds01). Test datastore has one test VM named vm1.

I will give you brief overview of my test scenario:

1. Action -> Backup->Daily withouth additional parameters fails. Error vmw-00010 query of datacenter failed.  (well, connection to vcenter server is OK I can confirm since I am able to choose which VMs or datastores to backup, In my case datastore is selected).

2. Action -> Backup -> Daily + sc_agent_timeout=1800 fails. Same error as in case 1.

I wait few minutes.....


3. Action -> Backup->Daily without additional parameters fails. Error vmw-00010 query of datacenter failed.

4. Action -> Backup -> Daily + sc_agent_timeout=1800 SUCCESS FINALLY!


Ok, finally I have backup, now restore test scenarios.


1. Restore -> Daily -> select snapshot -> no additional parameters FAILED. Error vmw-00016 query of virtual machines failed scf-00028 Auto Discovery for plugin failed (validation failed).

2. Restore -> Daily -> select snapshot -> + sc_agent_timeout=1800 FAILED. vmw-00010 query of datacenter failed. scf-00028 auto discovery failed (validation failed) ! Not same error as in restore case 1.)


Then I restart sc agent & server...maybe it helps because of java stack.


3. Action->restore->Daily->choose snap-> no additional params FAILED. Only error CF-00028: Auto Discovery for plug-in [vibe] failed with error [validation failed] and exit code [1], Exiting!. No more vmw-00010 and vmw-00016! Only scf-00028

4.Action->restore->Daily->choose snap-> + sc_agent_timeout=1800 - same error as in case 3.

5.Action->restore->Daily->choose snap-> + sc_agent_timeout=1800 + vibe_vsphere_names=vcenter01:testds01:vm1 FAILED! vmw-00010 query of datacenter failed, scf-00028 autodiscovery of plugin failed [validation failed]



6. Action->restore->daily->choose snap-> + vibe_vsphere_names=vcenter01::vm1 fails with error SCF-00052: Restore handling of plug-in [vibe] failed with error [null] exit code [1], Exiting! in restore handling for plugin vibe phase.



Anyone had similar issues? After finally getting backup procedure to work I am not able to do restore of whole datastore that is selected in backup, nor specific (and only virtual machine) as specified in case 5 using vibe_vsphere_names parameter.




Hi raskovicm,


If you have not please go with these  threads, it might help.


We will get back to you on this soon.







Thx, but  I use sc on windows host so first thread regarding linux  is not for me 😕

 Here I attach relevant logs for failed restore operation & config file.


Hi raskovicm,


1. please check the password once , reconfigure it in ui save it and rerun the restore.

2. try installing scAgent on the same machine where vcenter server has been installed. configure Agent in UI , save it and rerun restore .


vmw-00010 : Query of datacenter failed!

A general vSphere API error occurred while trying to query the list of data center objects in VMware. Review the event logs in the vSphere infrastructure client to remove any unwanted Snapshot copies.  








Password is correct since backup was successful for once and I can see VMs when browsing datastores through snap creator. Nobody changed password.

I am not able to install agent on vcenter server since vcenter is VCSA (virtual center server appliance). (just to clarify - tried with full vcenter server @ windows but with same issues).

There are no vmware snapshots - checked multiple times.

"Review the event logs in the vSphere infrastructure client to remove any unwanted Snapshot copies. " I did that and I found message in vpxd log as in attachment.


Based on your post I'd recommend opening a support case.

To troubleshoot we will need a scdump which will include the logs and configs.


Support can gather all of this info and should hopefully be able to advise you on where the issue lies.



I am not able to install agent on vcenter server since vcenter is VCSA (virtual center server appliance)

What error message it is giving? We should be able to do ssh with root/vmware and install linux scAgent on it.


I did not try that since it is security issue to install additional software to vcsa by internal policy. Now I use sc server on standalone windows server and agent on same server as sc server. Also I tried same with agent installed on different windows server but did not help.

I can try installing sc agent on virtual center server appliance if you suggest?

Please give a try. It should work.


Hi raskovicm,


Can you please share the update?








Did you find a solution for this problem ?



Kris Boeckx