Data Backup and Recovery

SnapCenter - Auto Clone SQL-DB's failed during mount/attach disc


Hi together,


I've got a small problem and I need your help with an Clone job in SnapCenter this job clone some db's  on a MSSQL instance and should map

this automatically to an different MSSQL server the cloned databases. This job was still running very well and it was really helpful to have a temporally

database environment. But after an Update migration from vmware 5.5 to 6 including the migration from vSphere vCenter on Windows to vShere vCenter appliance

it's not possible to run this job successful. But other task like backup and so on works with VSV, also the connection to SnapCenter Server is OK.

We are using SnapCenter (v 1.1.02958) and on a different windows server the VSC v6.2.1.


If I run the job manually that means prepare on the netapp an new clone and present for vmware, attach in vmware and extend manually on

the virtual machine a disc from this new datastore it works without problems.


Here the failure if I run the clone job

Failed to Mount/Attach Disk:- java.rmi.RemoteException: Exception in WSClient.invoke:; nested exception is:  java.lang.NullPointerException


I'am also able to work in vSphere with the VSC for backup's but strainge is i get for one machine also a failure message if I want to

attach this machine to an existing VSC Backup job.


faultCode:Server.Processing faultString:'java.lang.RuntimeException : java.rmi.RemoteException: Exception in WSClient.invoke:; nested exception is:
java.lang.NullPointerException' faultDetail:'null'



This are the step's which i still tested.


- Restart server (destination MSSQL Server, VSC Server, SnapCenter Server)

- Reinstall the SnapCenter Add-in on the destination machine

- Release and cleanup all Clones and mounting points and so on

- Shut down the destination machine and clone this maschine to release all connection and run only this machine
  (delete the old machine)

- Recreate the Clone job in SnapCenter


but all without success 😞


Did anybody have an idea!?

Thanks a lot for your help






The best thing to do is going to be to open a support case.

They would need to take a look through the logs and try to figure our why you are getting the errors.


Unfortuantely I haven't seen this error and can't offer any other advice.