Data Backup and Recovery

SnapCreator Agent Service does not start


Hi All,

on a few windows 2003 server the snapcreator service does not start.

BUT when starting the serice snapcreator.exe --start-agent works fine. I tried to google some info but seems Iam the only one with this problem. This is about the 4th server.

Is tehre a way to enable more logging to find out what is going on when the service tried to start ?

Best Regards


ANSWER: .net 3.5 need to be installed on windows 2003




The snapcreator exe and the Java exe should be of the same architecture either 32 bit or 64 bit.

If you have a mismatch the snapcreator service won't start.

You can verify the java version by running java -version -- if it is 64 bit you will have an output like below.

java version "1.6.0_18" Java(TM) SE Runtime Environment (build 1.6.0_18-b07) Java HotSpot(TM) 64-Bit Server VM (build 16.0-b13, mixed mode)

On a 32 bit, there will be no reference for the 64 bit Java version.

If your JVM and snapcreator exe are 32 bit and if you still have issues starting the service, please let me know.


C:\Documents and Settings\Administrator>java -version

java version "1.7.0_13"

Java(TM) SE Runtime Environment (build 1.7.0_13-b20)

Java HotSpot(TM) Client VM (build 23.7-b01, mixed mode, sharing)

Its win2003SP2 32bit


And the snapcreator.exe -- did you download the 32 bit exe as well?

Also, another thing to check is the port -

Snapcreator server runs on 8080 and agent runs on port 9090 if these ports are in use, you can't start the service as well.

NetApp Oncommand server also listens on port 8080 and if you have that running you may have a port conflict.


Snapcreator is 32bit, Its defiantly not a port issue

snapcreator.exe --start-agent start on port 9090 too and is working just fine afterwards.

Is there a switch you can give the scServerAgent.exe to tell you why it is unhappy?


I would ask you to reinstall the latest java, and reinstall snapcreator package again.

Also, this could help to collect the debug logs.

snapcreator --start-agent 9090 --verbose --debug


Hi Siva,

I do not have an issue with snapcreator --start-agent 9090 , this is working just fine and this how I have been testing the config and had not problems.

The issue is to start the SC Agent Service which is starting which is using scAgentService.exe , this is the problem programm. I can not even start it from the cmd to get some options to figure out whats going on.

Best Regards



Hi All,

ok the SCAgentService.exe which is started by the Service Manager is a small "wrapper" to start the snapcreator.exe written in .net. It is ecentially the interfave between the Windows Servive Manager and the snapcreator.exe.

After installing .net 3.5 the service started with no problems.