Data Backup and Recovery

SnapCreator GUI cron scheduler running inconsistancy.


I am currently using SnapCreator 3.3 Server on a Suse Enterprise 10 server.   I had two jobs that I scheduled via the SnapCreator GUI scheduler using the cron feature.  The jobs are staggered 15 minute apart.   Randomly, either job will just stop running.  In the scheduler it will sometimes show 'red' for the status, but no errors in the log dir (in fact no logs are generated).  It is set to run as verbose too.

Has this behavior been experienced before?  Using roots cron directly seems to work 'ok'.  For some reason on this system it took several hours before roots cron would actually run a simple cron job.  After further investigation and a support call they indicated roots cron may not always execute the jobs right away.  First ever I have heard that one, must be anomaly in SUSE; however, I did see several similar issues when surching on Google.

Not sure if these are related or if there are issues with the scheduler in SnapCreator.  

I would like to keep this on the SUSE server, however I do have a W2K8 server I can use if their are known issues on SUSE with the scheduler.  I would rather not use roots cron (the client would like to be able to leverage the GUI to schedule all jobs, since there will be multiple people on the staff with different skill sets.  And, would be nice to use the GUI since you don't have to log onto the server directly to change/monitor the job status).

Thanks for any feedback -



Well if the previous job is running and it tries to kick off the job again you would see this behavior, but I havent heard of issue. What does the cron sched you are using look like? Maybe try not using cron and use basic scheduling?




The jobs were not overlapping... that beings said, I also tried basic scheduling, same result where it would sometimes run, then not and the status would show as red, but no logs. 

If there has been no issues I would suspect there may be something wrong with the machine perhaps...




If the SC scheduler isnt working, I would use unix cronjobs. Under gui/logs you can see if there are any errors which tell us why job isnt starting.