Data Backup and Recovery

SnapCreator failed to create snaps using sdcli.exe


Hi All

I get the following error using the sdcli.exe for creating application consistent snaps

failed with exit code [1] and message [500 read timeout at /<D:\Program Files\Netapp_SC_3.3\scServer3.3.0\snapcreator.exe>SnapCreator/Agent/ line 288

Does anybody have an idea why?

It just a very simple configuration without any PlugIn like DB2 etc.

SnapCreatorServer can communicate with the SnapCreatorAgent using port 9090.

As OS W2K8 x64 Std/W2K3 x64 Ent is used.

Thanks a lot





Hi all

Additional info

I want to use SnapCreator for creating a SnapDrive SnapShot of a few (not all drives).

It's just a normal Windows Server 3003 x64 Entwithout any special databases/applications

Question: Is there any need that the SnapDrive services of the remote host (here the 2003 x64 Ent Server) must run with special users or is just local system ok?

Thanks for some useful feedback.




Hi Thorsten,

A read timeout means that the scServer timed out when communicating with the scAgent. I would look out how long SnapDrive takes to create a snapshot. Probably this is longer than timeout you have set in config for SC_AGENT_TIMEOUT. You can increase the timeout by increasing value for SC_AGENT_TIMEOUT, it is in seconds.

Other things to check:

1. Under scAgent3.4.0\config\agent.conf - make sure you have this like "command: sdcli". This makes sure that the agent will allow snapdrive commands, you can also do "command: *" to allow all commands.

2. Make sure agent ping works. Open profile in GUI and go to agent settings, then click "test agent".

3. If you aren't using GUI you can simply do a telnet "telnet <host> 9090"

4. Check to make sure user running agent has permissions to run snapdrive. Remember snapdrive requires admin permissions.

Again I am guessing this is issue with SnapDrive taking a while and SC_AGENT_TIMEOUT not being enough to account for it

Let us know if this helps?




Hi Keith

For the moment I'm using SC 3.3.3.

Now here my answers

1. * is set in the agent.conf to allow all commands

2. Using the GUI to test the agents works fine, reply is 0 seconds

3. Also telnet to 9090 works fine as well

4. SnapDrive is running with dedicated domain user which has local admin rights

I've set the SC_AGENT_TIMEOUT to 10 but I still get the same error.

Following command is used to create the SnapDrive snapshot

"c:/Program Files/NetApp/SnapDrive/sdcli" snap create -m gdcvitest02 -s %SNAME-%SNAP_TYPE-%SNAP_TIME -D  😧 E:

And you're right Keith. I've now set the SC_AGENT_TIMEOUT to 30 and now it works fine. It was set to 2 during the gui job creation. If nothing will be entered then the default of 300 sec will be used. Found that in the conf file. Maybe a hint would be helpful when useing the gui that the default value is ok and nothing should be entered. As I'm using SnapDrive for the SnapShots this will take more then 2 sec which was entered before 😉 So the default timeout is fine

Thanks for help Keith.

And I will come back 😉

Best regards



Hi Thorsten,

Thanks for feedback and reporting back that it works

We recommend SC_AGENT_TIMEOUT=60 but 30 should be enough unless something really bad happens with SnapDrive. i have seen SnapDrive take fore than 60 seconds even but that was unix env with LOTS of file systems.

We will add a hint in GUI, i agree this would be helpful with some guidance for different configurations