Data Backup and Recovery

SnapDrive 6.0


I am trying to install SnapDrive 6.0 on 2 of my exchange servers (Exchange 2003) and I keep receiving this message:


Error 1920.Service SnapDrive (SWSvc) failed to start.

Verify that you have sufficient privileges to start

system services and check you Event Log for more



When I go into the Application Event Viewer I am receiving this message:

The description for Event ID (101) in Source (SnapDrive) cannot be found.

The local computer may not have the necessary registry information or message

DLL files to display messages from a remote computer.  You may be able

to use the /AUXSOURCE=flag to retrieve this description; see Help and Support for

details.  The following information is part of the event: SnapDrive Web Service failed to

start Reason: The TransportManager failed to listen on the supplied URI using NetTcpPortSharing

service: the service failed to listen.


Any input would be greatly appreciated.



Are you running any kind of Exchange server online backup tool? If so, that may cause problems with the web services port. In the installation, change pop 808 to 4093 and see if that resolves your issue.



Nick - we have a snapdrive listener port that will not start on port 808 due to evault service.  We attempted to change SnapDrive to port 4093 - but cannot determine how to configure SnapManager for Exchange to talk to SnapDrive over port 4093.  We modified 3 config files that had many references to :808 and got it to sort of work - but continued to get errors.  If you know how to do this - please advise.




1. Create a user account in your AD domain. In my case I have an account called Snapdrive. Set the password and remember it like your first born.

2. Plop this account in the local admin group on your Exchange Server.

3. Open up an MMC and navigate to your Filer's Computer Management. Place the Snapdrive account in your Local Admin group on your filer.

4. Install Snapdrive.

This will take care of your permission issue.


Andrew Stack

Sony Computer Entertainment America



You definitely should review your user access configuration as mentioned by the others.

Within the SnapDrive User Guide, there are detailed steps to walk you through both host-side configuration as well as Filer Side.

This takes you directly to Configuring Access for SnapDrive

Let us know how that helps!


Christopher Kusek


If this server does not have Internet access the problem may be with the certificate revocation checking that SnapDrive 6.0 does. Go to Internet Explorer select Tools, Internet Options, Advanced. Then under security find "Check for publisher's certificate revocation" clear this option.

Richard Oestreich


This can also be addressed via SnapDrive 6.0P1, which fixes the issue with Certificate revocation checking.



I ran into this same error with Windows Server 2003 SP2 with SnapDrive 6.0.1. It turns out that if you don't have .NET Framework 3.0 _SP1_ installed, it can this error too. Make sure you have SP1 .NET Framework.


This involves the Net.TCP Port Sharing Service

How to: Configure a Windows Communication Foundation Service to Use Port Sharing


I had same issue on the server win 2003 R2 (64 bit)

the server had .net 3.5 SP1 installed on it but still it failed while upgrading from Snap drive 6.2 to 6.4.1D2

changing port to 4093 did not work

finally found that IIS Admin service was in dissabled state. enabled it and started the upgrade again which resolved my issue.

Screenshot for refrence