Data Backup and Recovery

Snapdrive in a clustered environment


Hi I am having issues with Snapdrive in a  Win2k8r2 clustered environemt and reading the admin guide doesnt seem to help. We are usign the latest version of 6.3R1

Upon further inspection (by letting the MMC just sit there for hours), what I’ve seen is that the drive will eventually be created. Unfortunately, it was about an hour between start to finish for it to complete every step. The “Checking for access control” was just one of the many step-by-step checks it had to do before creation.

Since then, I’ve tried creating more volumes. Every step using the wizard has had varying delay times, from seconds to minutes to tens of minutes. While Windows will try to error out, saying that the snap-in is not responding, if I let it sit there, it will eventually proceed to the next step.

I’ve tried this on multiple volumes on multiple hosts, so I don’t believe the issue is strictly bound to a single host. I don’t believe that this delayed behavior is at all necessary. At the current rate, it could take me about 12 hours to create enough LUNs for everything. I’d like to see if we can determine the cause of the problem, and how to resolve it.




Well, that's definitely abnormal behaviour.

Have you got any sample logs covering a period when such delays occur?




I'm using SnapDrive in a Win2K8R2 cluster without similar issues.  Are you using FC, iSCSI, or FCoE?  Have you confirmed that all components are using the correct versions from the NetApp Interoperability Matrix Tool?

Here is the link:

It is essential that you have the correct version of the Host Utilities Kit, HBA firmware and driver, etc.


One thought:

SnapDrive always checks whether all cluster nodes are in a healthy state - if they aren't, it will actually refuse to do certain operations.

Is the communication between nodes OK? Is it using fairly decent network?


We had two issues with Snapdrive 6.3x and Windows 2008 r2 clustering: 

1.  Error:  The RPC Server is unavailable (when trying to create luns).   - All nodes in the cluster must have the proper inbound and outbound rules to allow  SWSvc.exe.  Troubleshooting this by turning off the firewall doesn't work...the only way you will see it work with the firewall off, is if the windows firewall service is also stopped.  With firewall on, just ensure you have the inbound and outbound rules defined on all nodes in the cluster.

2. Access is denied (when trying to create luns) - Once we got the firewall issues resolved, this was the next problem.  This problem occurred for us when we didn't have Snapdrive installed on all nodes in the cluster.  This is necessary even if you aren't going to attached any NetApp luns on a particular node.  Ensure you have Snapdrive (same version) installed on each node in the cluster!  In a clustered scenario, Snapdrive needs to communicate with all nodes.  Good luck!


I had same problem, and it has to do with Firewall, Let me go back to my notes and get back to you..