Data Backup and Recovery

The size of volume increases after restore


Hi ,

SMO version           :  3.1

OracleDB version    :   9.2

OS system             : HP-UX 11.23

I tried to restore database from the backup I took before ,everything worked well . But when I check the volume on where database is created ,I see that the volume increases from 63Gb( before restore) to 70 GB (after restore) .I really don't know why the volume is increased abnormally ?

Best Regard




Hi Tien,

when you are doing restore some files can be overwritten and can cause higher ratio change. The best example of that is for example Oracle resetlogs operation which rewrites whole Oracle active redo log files.

If something would go bad then perhaps you could end up in host side restore, which could result in overwriting all Oracle data files (instead of revering the vol snaps/LUN snaps on the storage directly)... (this depends on the storage layout used).

In short: it depends on the way which SMO choose to restore the database (storage side, host side, etc), there are too many factors and not enough data.



Thank you ,Jakub,

After I separate ORACLE_HOME and datafiles . It works now but it takes very long time (about 9 min) to restore a 5Gb database .

Can you please help me to solve this problem ?

Below is a summary of operation configuration(Before restore) :

Restore conf info :

Restore control file  No

Reroore datafiles or tablespaces : YES

Retore shutdown or database if necessary : YES

Recovery to Perform :No Logs

Use Backup Controlfile : No

Restore Source Location Use local storage for the retore

Volume Restore Conf Info

Perform volume restore ,overriding if an overriable volume restore is possible

Logfile after restore

-[ INFO] ORACLE-20000: Changing state for database instance TESTSMO from MOUNTED to OPEN.

--[ INFO] ORACLE-20032: Opening database TESTSMO with  RESETLOGS option.

--[ INFO] SD-00016: Discovering storage resources for vgnetapp_archive_0.

--[ INFO] SD-00017: Finished storage discovery for vgnetapp_archive_0.

--[ INFO] SD-00037: Beginning to disconnect volume groups [vgnetapp_archive_0].

--[ INFO] SD-00038: Finished disconnecting volume groups [vgnetapp_archive_0].

--[ INFO] SMO-07131: Unlocked database for SnapManager operations - removed lock file "/SMO/oracle/product/10.2.0/dbs/.sm_lock_TESTSMO" on host

--[ INFO] SMO-07433: Returning the database to its initial state: TESTSMO(SHUTDOWN).

--[ INFO] ORACLE-20000: Changing state for database instance TESTSMO from OPEN to SHUTDOWN.

--[ INFO] SMO-13048: Backup Restore Operation Status: SUCCESS

--[ INFO] SMO-13049: Elapsed Time: 0:08:26.974

--[ INFO] Operation Id [8a2aa0b2307a052801307a05336e0001] succeeded.

Best regard