Data Backup and Recovery

VSS timeout with SnapDrive 6.2


I am running Windows 2003R2 32-bit with SnapDrive 6.2 and FAS2050 running OnTap 7.3.2.

When I try to run a backup using VSS, the VSS snapshot creation fails. I traced it back to a timeout that occurs when taking the snapshot.

Every time I run the backup (or try to create a VSS snapshot), I get the following warning in the Application log (see attached screenshot):

"Data ONTAP VSS hardware provider has completed CommitSnapshots for SnapshotSetId {00043bf4-0047-47d0-b4f8-23718c53d9eb} in 10156 milliseconds. Since it takes more than 10 seconds, this can fail the current shadow copy."

The duration changes slightly in the range around 10100 to 10300 miliseconds. The snapshot on the filer is created successfully and deleted immediately afterwards.

Any ideas how to troubleshoot this?



Screenshot of the Application log warning event attached.


Can you create a snapshot manually from CLI?

Do you have other services running on this server maybe, such as backup exec or volume shadow copy for windows (I forget the exact name, but it's Microsoft's "snapshot" technology).


Yes, I can take volume snapshot through the filer CLI successfully.

Yes, I can also take a LUN snapshot using SnapDrive in Windows.

Yes, there is both backup software (Tivoli Storage Manager) and VSS running on the server - that's the core of my problem.

When SnapDrive is installed on a Windows server, it installs the Data ONTAP VSS Hardware Provider. It integrates the SnapDrive
service and storage systems running Data ONTAP into the VSS framework.

This is my naive way of thinking about the process:

  1. When Tivoli wanst to run a backup, it asks VSS for a consistent 'snapshot' of the NTFS file system for the disk it is about to back up.
  2. VSS looks at the disk, finds out that it is a NetApp LUN, so it asks the Data ONTAP VSS Hardware Provider for a snapshot.
  3. The VSS provider then talks to OnTap, gets the snapshot and then makes it available to VSS, which then makes it available to Tivoli.

My problem is somewhere between steps 2 and 3 - that is, VSS times out waiting for Data ONTAP VSS Hardware Provider to take the snapshot. The timeout is 10s and Data ONTAP VSS Hardware Provider misses it by 0.1 of a second.


I ran into a similar problem with CA Arcserve backup.  Whenever my backup server went across the network to backup a server attached to a NetApp LUN, it would force a snapshot of that LUN before backing any data up on it.  I could see it in the messages log of the filer.  This was not desirable behavior.

I was able to resolve the issue by configuring my CA Backup jobs to NOT use VSS when they perform a backup.

I'm not sure there is a way to have your backup application use VSS, but not leverage Snapdrive and the ONTAP VSS hardware provider.  I'm not familar with Tivoli, but can you disable VSS for those backups on NetApp LUNs?


Thanks. For now, the issue has disappeared. Previously the 10s VSS timeout was exceeded by only 0.1 s, I am guessing now things have gone below 10s.

Turning off VSS is not an option - I want VSS to work. Without VSS, I would not be able to back up open files, which is important on a file server.

Decoupling VSS from NetApp snapshots could possibly work, but I don't like the idea of hacking stuff - if it was designed to work this way, then it should work (you can call me an idealist).