Data Backup and Recovery

smo clone error


--[ INFO] SMO-07337: Recovering database clone "EXP002" to a consistent point using archived logs from the backup.

--[ INFO] ORACLE-30008: Beginning recovery process for database EXP002.

--[ INFO] ORACLE-30010: Database recovery point objective: earliest consistent point

--[ERROR] SMO-13032: Cannot perform operation: Clone Create.  Root cause: ORACLE-00001: Error executing SQL: [RECOVER DATABASE USING BACKUP CONTROLFILE UNTIL CANCEL;].  The command returned: ORA-00279: change 859111512 generated at 10/04/2011 00:05:01 needed for thread 1

ORA-00289: suggestion :

ORA-00280: change 859111512 for thread 1 is in sequence #3258

ORA-01547: warning: RECOVER succeeded but OPEN RESETLOGS would get error below

ORA-01195: online backup of file 1 needs more recovery to be consistent

ORA-01110: data file 1: '/u02/oradata/EXP002/system01.dbf'

ORA-01112: media recovery not started

Just looking in the repository I can see what appears to b einformation regarding the details of the files involved in this particular backup. It appears to list only one archivelog. Is this expected? Should itcontain all of the archivelogs i.e. the one that is says it can’t find?

Further to my xml backup other backups where cloning work sappear to have multiple entries for archivelogs in the artefact. Would amendingthis XML work since we have sod all to lose?




Just an update. I have tried to edit the xml file, but I still get the same errors.



I am wondering whether this might point to the bug. Has anybody been in this scenario before ??

Bug ID237893
TitleClone from online backup can fail with SMO-07341 or SMO-07340 in certain situations
Duplicate of
Bug Severity3 - Serious inconvenience
Bug StatusFixed
Bug TypeSnapManager for Oracle
 If the database is under high load, multiple archived logs (per redo thread) can be generated while the database is in "hot backup mode" for an online backup.    If that online backup is used as the source for a clone operation, these logs will need to  be applied to the clone database in order to recover the clone database to a consistent point.  If multiple archived logs (per redo thread) need to be applied to the clone, SnapManager for Oracle will fail to apply these logs correctly, resulting in a SMO-07341 or SMO-07340 error.
 Retry the clone operation using either: A. An offline backup B. An online backup where there is only a single archived log (per redo thread) generated while the database was in "backup mode".


I have a VBScript (uses DMO) that will script out a 2000 server and I believe has what you need. In essence, it creates a script that will build an empty clone of the source database. The logins don't have passwords but with 2000 you can bcp out sysxlogins and that will have the binary of the encrypted password.

If you think this will help, PM me and I'll email it to you.

jamon iberico

*LIFE'S SHORT. If you don't look around once in a while you might miss it*