Data Backup and Recovery

snap drive performance


I recently installed SnapDrive 6.1 on a Windows 2008 virtual server.

When creating luns it takes 15 to 20 minutes to get a volume list to come up.

This is my first experience with SnapDrive. Is this normal?

I've also installed SnapManager for Exchange and moved the storage groups and logs to the luns.

Backups are unsuccessful though with VSS timeout errors.

Technical support has requested a perfstat but I can't get it run. RSH is disabled on the filer. I tried with SSH but that fails as well despite opening a plink connection to the filer as the documentation specifies.

Thoughts/ ideas on any of this?



Hi Parker,

Lets fix one by one.

1. rsh .

login to the filer. do "options rsh". enable it. Then open the file /etc/hosts.equiv. Add the snapdrive host name & SME hostname. This makes sd host & sme host execute commands on the filer with out the need for passwd

2. SD & SME.

Please make sure SD & SME are installed & run by the user who is part of admin group on the host & also on the filer. Eg: I've a svc-snapdrive account which is part of administratos groups on my filer and also on the hosts.

What is the exact vss error message. There can be many reasons why vss will fail.

Thx, Satty


I'll have to see if turning on RSH is allowed   This is the error in SME.    [09:22:14.126] Error in calling VSS API: Error code = 0x80042314 Error description: VSS_E_HOLD_WRITES_TIMEOUT   It appears that the server doesn't get confirmation that a Netapp snapshot has been taken within the 10 second limit for VSS.   I am logging in using a user name that has Administrator privileges on the host and the filer.     Any comment on the length of time it takes to get a volume listing in snapdrive when creating luns?  There are 130 volumes on the filer (3050c) is it normal to take that long to get a volume listing?  


It shouldn't take long to see the volume listing. I'd see 1-2 sec. if not, we need to know why ?. The best way is to read the /etc/messages file on the filer while the volume listing is gojng on . That should give us some details


->Can you check volume is full, number of snapshots on the volume ( should not be more thann 255)

-> Restart the Snapdrive & SME services & start the backup. ( Some times it works,as it releases VSS hung process)

Lemme know the results.



The volume has plenty of space and has 0 snapshots.

I've recycled/rebooted everything wih no change.

I can see that the requested snapshots are created and then deleted when the job fails in the syslog messages.

I'm suspecting some type of communication issue between the host and filer.

This filer returns different names, one with an underscore in DNS as it was named with an underscore in the name and a dash in it for a netbios request as the underscore is not allowed. When I ping the dns name of the filer from the server it returns the private address used by iscsi and NFS connections to the filer. If you ping the netbios name it returns the public management address. When you look at the luns they display the netbios name.

I' tried setting the preferred ip address in snapdrive to the private address but that made no difference.


Hi Parker,

Try setting Preferred IP address which can be accessed from multiple vlans. What does the event viewer say on sd host



It appears there may be a bug in Snapdrive 6.1 using http or https access.

I cahnged the protocol settings to use RCP upon request from support and was finally able to run a successful SME backup.

The volume list now comes up in about 10 seconds as opposed to the 15 to 20 minutes it was taking.

From the suppport engineer:

"I have seen a bug that affect SME 5 and was fixed in 6 but I suppose it is possible we may have reintroduced it in 6.1 were we get a simular behavior using the http or https Transport Protocol Setting. If possible please set this to RPC for a test."