Data Backup and Recovery

snapcreator 4.1.0c xen wrapper dies out-of-memory



I am using Linux-only shop. I am backing up Citrix XenServers with SnapCreator installed on Linux.

I added the path to the xe (/usr/bin) and a directory created to allow metadata, as required. 'xe' command is installed and functioning on the SC server correctly. I installed the agent on the same server.


When running 'discover', the process times out. It claims to have failed, and returned value 101 in the xen discovery phase. 

When I run 'strace' on the wrapper process on the said Linux machine, I got 'out of memory' of the process. This is a rather small XenServer pool, with few machines, so it should (and in CLI, actually does) respond very fast. 


I created a Windows machine with XenCenter on it, and used it (with agent, of course) and got there a different problem. It worked there, however, the metadata backup fails, because the target path has slashes and not back-slashes (while I did configure it with backslashes). 

So - I cannot backup XenServer either way.


How should I proceed?




Is there a reason that you are using that version of Snap Creator?

The very first suggestion that I would make is to try with the latest version of Snap Creator.


4.1.0.c is a pretty old release, and the c (community) releases are not supported.


4.1.1 is the latest:


Since you are using the XEN plugin you would be able to engage support if you were using a supported release.


This may be something that has since been fixed - I'm afraid I don't know much about the XEN plugin.


Sorry I don't have more info for you.