Data Backup and Recovery

the NTFS file system does not have enough free space to shrink the disk to the size entered

TDUBB1234
3,957 Views

I have a iscsi lun mapped to a windows vm. when i tried to shrink that lun It says

the NTFS file system does not have enough free space to shrink the disk to the size entered. Enter a valid disk drive size

the drive is empty and nothing on it.

8 REPLIES 8

shaunjurr
3,957 Views

What is "It"?  Please be specific.

TDUBB1234
3,957 Views

its empty

shaunjurr
3,957 Views

What software and command is giving you the error message?

Answering "its empty" to the question "What is 'It' [sic]?" is just not helpful.

TDUBB1234
3,958 Views

snapdrive for windows

shaunjurr
3,958 Views

If you previously had data on the LUN, then you will need to use space reclamation before you can resize the lun, I believe. I believe there is also a limit to how far (in percent, iirc) you can reduce a filesystem with snapdrive as well and only on win2008, iirc.  I'm no wizard on the windows add-on software, so perhaps you will get a better answer soon.  At least everyone has a better idea of what you are actually having problems with.  Always be as specific as possible with your questions and answers.

TDUBB1234
3,958 Views

wow, i resized it from command line

lun resize /vol/iscsi/iscsi_qtr/iscsi_vol0 -4g

it did resize it

but

when i went to the windows vm on snapdrive and rescanned it did show the drive as resized.

but in my computer is still shoed the old size.

So I went into windows disk management and rescanned. and it showed the new size.

BUT

it lost the drive letter and now the disk is showing as RAW not NTFS. so i guess this method of shrinking a lun makes you lose your drive and data?

TDUBB1234
3,958 Views

there is a iscsi volume for 10gb

iscsi lun of 8gb created from this

i mapped this to a windows vm and installed snapdrive on it.

I see 7.9 gb volume in snapdrive. But I cannot shrink it

Bigadds
3,069 Views

hi

 

i am having this problem , i was hoping to remove 500GB from an iscsi attached LUN

 

current size is 1.8TB and tried to resize to 1.3 before getting the error

 

i cannot afford to loose and data during the process

 

i am using snap drive to do this

 

any pointers please

 

 

thx

Public