EF & E-Series, SANtricity, and Related Plug-ins

firmware revert

jackson_lee
700 Views

Hello .

My  E2824 firmware verion is 11.73. I need to revert it to 11.60.3.

When i tried to firmwware downgrade on smcli using bellow command

 

downlod storageArray firmware file="c:\RCB_11.60.R2_280x_5fab8f6.dlp" downgrade=TRUE  activate=TRUE  healthCheckMelOverride=TURE;

 

always downgrade failed. 

How can I revert it ?

failed.PNG

santricity.PNG

 

 

1 ACCEPTED SOLUTION

MitchBlackburn
679 Views
I tested this with the following command, and it worked properly using Storage Manger script editor. This also lets you verify the syntax before executing.

download storageArray firmware file="c:\RCB_11.60.3R2_280x_5fadb8f6.dlp" downgrade=TRUE activateNow=TRUE healthCheckMelOverride=TRUE;

Please note the command you showed had several mistakes. Also, of note use of activateNow instead of just activate. Further, this can take up to 15 minutes to execute.

Mitch

View solution in original post

3 REPLIES 3

MitchBlackburn
680 Views
I tested this with the following command, and it worked properly using Storage Manger script editor. This also lets you verify the syntax before executing.

download storageArray firmware file="c:\RCB_11.60.3R2_280x_5fadb8f6.dlp" downgrade=TRUE activateNow=TRUE healthCheckMelOverride=TRUE;

Please note the command you showed had several mistakes. Also, of note use of activateNow instead of just activate. Further, this can take up to 15 minutes to execute.

Mitch

jackson_lee
624 Views

Thank you for your answer.
Whenever  running this command, I checked syntax first but there is no error. Also I restarted a santricity when error occurred if i have error because of wrong word.

I check  my hardware stratus, there is no error.

syntax.png

status.JPG

I already opened the case, but case  owner gave me a same command.

 

jackson_lee
463 Views

 

I solved the problem.

Below is what I did for reverting.

1. When I revert to 11.60.3R2 from 11.73, Santricity always gave me a same error.

     I couldn't  look for exact reason.   

 

2. I was trying to revert it to lower version (maybe 11.40) ,   ended up it was complete         

    successfully.

 

3. I upgraded OS  to  11.60 from 11.40 .  When I upgrade it, there was no error.

 

Thank you.

Public