Microsoft Virtualization Discussions

CIFS SVM not displayed on VMM (file-server section)


 hi folks,


i've installed SMI-S on a guest VM, my customer and I, configured it following the best practices but my CIFS server does not show up in the SCVMM even if it is configured in SVM.

Export-policy OK

volume created OK

connection from VMM to SMI-S agent OK

firewall policy set to management on the data lif.


the smi-s agent is listed in Providers with status repsponging

the svm is listed in Storage/Arrays with status responding


but the SVM does not show up in file-server ... 

Licences are OK .


DOT 8.2.2P1 / SCVMM 2012R2


any idea ? 



do you have different names vor the SVM and the CIFs server?




Hi Andrea
Thanks for the reply.
Yes they have differents name.
I tried to use name without dash ("-") but Without success.


Sometimes you can get an idea by looking in the logs. Usually located at \Program Files (x86)\Ontap\smis\pegasus\logs


But a quick checklist of things I'd go for (off the top of my head):


1. Make sure the action account used to add the SMI-S provider into VMM is a local administrator on the SMI-S server.

2. Make sure the SMI-S provider and VMM are not on the same server.

3. Make sure the CIFS server is running on the SVM "cifs show -vserver <SVM name>"

4.  Make sure the CIFS server is in the same domain as the VMM server.

5. Make sure the action account used to add the SMI-S provider is listed in the "cimuser -l" output on the SMI-S server (assuming authentication is enabled, which it is by default).


Hi bingen,


Communication between SMI-S agent and vserver seems to be OK:

the new created volume by CLI comes up in VMM.


i've tried changing the SVM name to match the CIFS server Name, still the same : svm not displayed in "file server" section on VMM.


SVM and VMM in same AD.

CIFS is running.


I'll check the logs