Microsoft Virtualization Discussions

Highlighted

Cluster Setup Fails - Cannot connect to node IP to start New-NcCluster process

Trying to use the New-NcCluster cmdlet to start the cluster setup process.  The node IP is configured using node setup and the admin password is set. 

 

The next step is to connect to the node IP using Connect-NcController but the connection fails. 

 

Connect-NcController 192.168.137.201 -Credential $cred
Connect-NcController : Could not connect to 192.168.137.201 on port 80 for protocol HTTP.
At line:1 char:1
+ Connect-NcController 192.168.137.201 -Credential $cred
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidResult: (192.168.137.201:NcController) [Connect-NcController], NaConnectionException
    + FullyQualifiedErrorId : HttpConnectionFailed,DataONTAP.C.PowerShell.SDK.ConnectNcController

This shows the connection tried HTTPS then down to HTTP. 

 

Here's an attempt forcing HTTPS

Connect-NcController 192.168.137.201 -Credential $cred -HTTPS
Connect-NcController : database cluster_id_rdb is not open
At line:1 char:1
+ Connect-NcController 192.168.137.201 -Credential $cred -HTTPS
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidResult: (192.168.137.201:NcController) [Connect-NcController], EAPIERROR
    + FullyQualifiedErrorId : HttpConnectionFailed,DataONTAP.C.PowerShell.SDK.ConnectNcController

Without a connection the New-NcCluster is useless (obviously).  

 

Also, the web browser interface to run cluster setup doesn't work either - just get a blank page.

 

This has been attempted on a FAS2552 running 9.6P4 as well as the latest simulator.

 

Tried PSTK 9.6 and new 9.7.

 

BTW - this DID work in older versions - but it's been a while since I've tried it so couldn't say WHEN it broke Smiley Wink

 

Any ideas?

2 REPLIES 2
Highlighted

Re: Cluster Setup Fails - Cannot connect to node IP to start New-NcCluster process

Hi,

 

Are you still stuck ?

 

Please take a look at this KB:

HTTPS connections to controllers or clusters fail after installing Microsoft update 3174644 or 3175024:
https://kb.netapp.com/app/answers/answer_view/a_id/1070970/loc/en_US#__highlight

 

Let us know.

 

Thanks!

Highlighted

Re: Cluster Setup Fails - Cannot connect to node IP to start New-NcCluster process

Since the system is not yet a cluster there's not much that can be done as far as certificates (at the node level).  There isn't even a "security certificate show" command - only option is "install" (which fails btw). 

 

I did try to enable ssl with "ssl modify -vserver Default -server-enabled true" which generates a self-signed certificate (according to the Warning/Y|N message), but that throws a "Node '' on ring "Management" is offline error.

 

Besides, if I have to do all this on each node I might as well run cluster setup - intent is to automate the entire process. Smiley Wink

Try the NEW Support Site!
NetApp Support Site
Forums