Microsoft Virtualization Discussions

Data ONTAP PowerShell Toolkit 3.2.1

rajeshr
30,456 Views

Hi PowerShell community,

Very glad to announce availability of Data ONTAP PowerShell Toolkit Version 3.2.1. Please see release notes below.

Thanks!

Team

 

 

Version 3.2.1 release notes:

 

Download location

The Data ONTAP PowerShell Toolkit can now be downloaded on the NetApp support site: http://support.netapp.com/NOW/download/tools/powershell_toolkit/

 

Major features

  • Full Data ONTAP 8.3 API support

Toolkit 3.2.1 includes complete API coverage for Data ONTAP 8.3.  This includes 141 new cmdlets and 42 updates to existing cmdlets..

The following are new categories of cmdlets introduced in Data ONTAP 8.3:

  • nameservice - 10 new cmdlets
  • netgroup - 2 new cmdlets
  • ntp_server - 6 new cmdlets
  • tape_mc - 9 new cmdlets
  • cluster image - 13 new cmdlets
  • lock - 2 cmdlets
  • coredump - 1 cmdlet

The following categories have new cmdlets added:

  • lun (23 cmdlets)
  • system (1 cmdlet)
  • cluster (2 cmdlets)
  • cf (cluster-failover) (1 cmdlet)
  • feature (2 cmdlets)
  • volume (5 cmdlets)
  • net (4 cmdlets)
  • clone (10 cmdlets)
  • file (9 cmdlets)
  • disk (2 cmdlets)
  • metrocluster (4 cmdlets)
  • service processor (14 cmdlets)
  • autosupport (6 cmdlets)
  • system (4 cmdlets)
  • fpolicy (1 cmdlet)
  • gpo (2 cmdlets)
  • perf (2 cmdlets)
  • iscsi (1 cmdlet)
  • ses (2 cmdlets)
  • file-directory-security (1 cmdlet)

Enhancements

  • Parameter additions to various cmdlets
  • Ping-NcHost now supports IPv6
  • Specifying OwnerID is mandatory for Switch-NcDiskOwner for Data ONTAP versions later than 8.2.1
  • The Attribute parameter in cmdlets Add-NcNfsService, Set-NcNfsService now supports extra fields - AuthSysExtendedGroups, ExtendedGroupsLimit, MountdPort, NlmPort, NsmPort, RquotadPort, PermittedEncTypes, Showmount, NameServiceLookupProtocol, IsNetgroupDnsDomainSSearch
  • Get-NcServiceProcessor can return information for all nodes in a cluster now. Added filtering options like status and IsIPConfigured as parameter
  • Get-NcServiceProcessorNetwork and Set-NcServiceProcessorNetwork have been updated to work across multiple nodes

Check out "Making the Most of Data ONTAP PowerShell Toolkit" for more details on the new features.  If you're new to PowerShell or the Toolkit, you might want to start with our "Getting Started" slides.

 

23 REPLIES 23

ecker
27,467 Views

Hi...

 

I have a need for a cmd-let in cDOT:

 

Start-NcDiskReplace (on 7-Mode it's Start-NaDiskReplace)

 

Will this come in the future?

 

Cheers,

 

Mike

Randy
28,491 Views

I installed the tool kit and when i try to import eh module i get this:

 

PS C:\> Import-Module DataONTAP
Import-Module : Could not load file or assembly
'file:///C:\Windows\system32\WindowsPowerShell\v1.0\Modules\DataONTAP\OntapiPS.dll' or one of its dependencies.
Operation is not supported. (Exception from HRESULT: 0x80131515)
At line:1 char:1
+ Import-Module DataONTAP
+ ~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (:) [Import-Module], FileLoadException
    + FullyQualifiedErrorId : FormatXmlUpdateException,Microsoft.PowerShell.Commands.ImportModuleCommand

 

 

What did I do wrong?

Aparajita
28,465 Views

Hi Randy,

 

Can you try importing the module with the full-path (`Import-Module <install-path>\DataONTAP`)?

 

The default install path is "c:\Program Files(x86)\NetApp\DataONTAP" (or c:\Program Files\NetApp\DataONTAP in case of 32-bit Windows).

 

Let me know if this doesn't solve the issue.

 

- Aparajita

LITTLEREDCAR
11,004 Views

i tried the full path and i get this error message

 

 

LITTLEREDCAR
10,994 Views

Uninstalled/Reinstall .Net 4.5 --> Reinstalled Powershell Module 321.MSI

Import-module "full path" DataOntap

 

Import Successfull!!!!

 

 

Thanks

 

 

frhell
10,984 Views

Hi, can you share the utility? I cannot download....

Thanks

Aparajita
7,016 Views

Hi frhell and swe,

 

Can you please try the new download link (for NetApp PowerShell Toolkit 4.0, which contains DataONTAP PowerShell Toolkit 3.3)?

 

Please verify you are logged in to mysupport.netapp.com when trying to access the link. Being logged in to community.netapp.com might not be enough for the download link to work.

 

Hope this helps,

Aparajita

frhell
7,013 Views

It works!

JIATI0111
8,021 Views

Randy, did you get your PowerShell Toolkit 3.2.1 successfully installed? I got same error whoile loading , even tried providing pull path.  Thanks, Timothy.

Aparajita
5,991 Views

Hi JIATI0111,

 
I encountered a similar problem once - the culprit turned out to be blocked dll-s. Have you checked if the toolkit's files are blocked? (Right-click on the DLL file PowerShell throws the error for, select properties and see if an "Unblock" option appears. Select that to unblock the file)

 
Do let me know if this helps,
Aparajita

RaviTeja1988
28,296 Views

Hi All,

 

I am not getting all cmd's in my powershell window. Can anyone help me on this issue please.

 

PS I:\Scripting> Get-Command -Module DataONTAP

CommandType Name ModuleName
----------- ---- ----------
Alias Add-NcHostIscsiConnection DataONTAP
Alias Connect-NcHostIscsiTarget DataONTAP
Alias ConvertTo-NcLun DataONTAP
Alias ConvertTo-NcVhd DataONTAP
Alias ConvertTo-NcVhdx DataONTAP
Alias ConvertTo-NcVmdk DataONTAP
Alias Copy-NcHostFile DataONTAP
Alias Disconnect-NcHostIscsiTarget DataONTAP
Alias Dismount-NcHostVolume DataONTAP
Alias Dismount-NcVirtualDisk DataONTAP
Alias Format-NcHostVolume DataONTAP
Alias Get-NcHostDisk DataONTAP
Alias Get-NcHostFcAdapter DataONTAP
Alias Get-NcHostIscsiAdapter DataONTAP
Alias Get-NcHostIscsiSession DataONTAP
Alias Get-NcHostIscsiTarget DataONTAP
Alias Get-NcHostVolume DataONTAP
Alias Get-NcHyperV DataONTAP
Alias Get-NcVirtualDiskAlignment DataONTAP
Alias Get-NcVssProvider DataONTAP
Alias Get-NcVssSnapshot DataONTAP
Alias Get-NcVssWriter DataONTAP
Alias Initialize-NcHostDisk DataONTAP
Alias Invoke-NcHostVolumeSpaceReclaim DataONTAP
Alias Invoke-NcVirtualDiskSpaceReclaim DataONTAP
Alias Invoke-NcVssBackup DataONTAP
Alias Mount-NcHostVolume DataONTAP
Alias Mount-NcVirtualDisk DataONTAP
Alias New-NcHostVolume DataONTAP
Alias New-NcVirtualDisk DataONTAP
Alias Remove-NcHostFile DataONTAP
Alias Remove-NcHostIscsiConnection DataONTAP
Alias Remove-NcHostVolume DataONTAP
Alias Repair-NcVirtualDiskAlignment DataONTAP
Alias Restore-NcHostFile DataONTAP
Alias Set-NcHostDisk DataONTAP
Alias Set-NcHostVolumeSize DataONTAP
Alias Set-NcVirtualDiskSize DataONTAP
Alias Start-NcHostDiskRescan DataONTAP
Alias Wait-NcHostDisk DataONTAP
Function Add-NaHelpInfoUri DataONTAP

Lee_Sydenham
27,003 Views

Hi,

 

I hope somebody can help with what is probably quite a simple query. I have a FAS3240HA with no CIFS license and would like to use PowershellONTAP. When I try connecting I get an RPC error and from searching online, it appears that I need to run cifs setup to resolve. Is this something I should be able to do without a CIFS license? Or is there another way I can overcome this without running CIFS Setup?

 

Thanks,

 

Lee

Aparajita
26,984 Views

Hello Lee,

 

Without knowing what the exact RPC error is, it is difficult to suggest a resolution.

 

But a workaround would be connecting using HTTP/HTTPS (syntax below). 

Connect-NaController <controller name or ip> -HTTPS

Hope this helps!

frhell
26,749 Views

Hi, i can't download tool...i have "Unauthorized access"...
Can you help me?

Aparajita
26,646 Views

Were you logged in to your NetApp Support account when you got the "Unauthorized access" error? The toolkit download requires you to be logged in to http://mysupport.netapp.com.

frhell
26,629 Views

I'm logged into mysupport, but i have always Not authorized...

frhell
11,207 Views

anyone have same problem?

someone can share the download directly?

thanks in advance

JH
11,156 Views

Is you email address yhoo or gmail? If it is NetApp wants a company email address.

swe
11,087 Views

Me too can not get to the download page. It responds with 401 - Unauthorized Access.

I have registered with a company email address and supplied SystemID for a NetApp unit.

 

I am also logged in at the site (or else I would not be able to write this).

Please advice or publish a working download link, or send it as a PM.

 

Thanks & regards

KANNAN_PRAKASH
7,468 Views

Could you help me with the cmdlets which can be used with power shell 2.0

Public