Microsoft Virtualization Discussions

Get-NcVolumeEncryption

twodotohh
1,442 Views

Using PSTK 9.8 (and this was the same in 9.6) running Get-NcVolumeEncryption gives an error back to say it is unable to find the API, does anyone else have this issue?  Trying to find a way of getting the encryption type of a volume, so volume or aggregate.  I can get whether or not a volume is encrypted but I am wanting to know the type.

 

Other cmdlets work fine, just this one, I had read on a previous community post this API might have been revoked a while back but this doesn't make sure to have not been reintroduced. 

 

Thanks

1 ACCEPTED SOLUTION

ttran
1,233 Views

Hello Twodotohh,

 

I confirmed the issue on PSTK 9.8 and have reported it to our internal team. Thanks for informing us and we apologize for the inconvenience.

 

 

Regards,

 

Team NetApp

Team NetApp

View solution in original post

4 REPLIES 4

Jim_Robertson
1,342 Views

What version of OnTap are you running?  I think it's more of an issue of what APIs are available in the OnTap version that you are connecting to, but I'm having the same issue.

I'm having the issue with Get-NcVolumeEncryption  and Invoke-NcVolumeEncryptionRekey.  I've tried running them PSTK 9.8 against an OnTap 9.7P12 cluster and from PSTK 9.6 against an OnTap 9.5P3 cluster.  Both cases report that they are "Unable to find API". 

Interestingly enough, Get-NcVolumeEncryptionRekey (to check the status of rekey operations) does work in both of the above cases. 

twodotohh
1,334 Views

I have tried on the exact version you mentioned and yes other cmdlets in that family do seem to work OK.  I suspect this needs fixing!

ttran
1,234 Views

Hello Twodotohh,

 

I confirmed the issue on PSTK 9.8 and have reported it to our internal team. Thanks for informing us and we apologize for the inconvenience.

 

 

Regards,

 

Team NetApp

Team NetApp

mcgue
873 Views

Do we have a bug open on this?  Looks similar to this other post that pointed to an API change.

 

Solved: Volume encryption details in PowerShell Toolkit - NetApp Community

Public