Microsoft Virtualization Discussions

Mat4Shift - ConvertTo-NcVhdx failing with Object reference not set to an instance of an object




We're just trying to use Mat4Shift 1.7 to convert some VMware VMs into Hyper-V format and it's randomly failing at the conversion stage when running the ConvertTo-NcVhdx command.


It seems to be hit and miss with VMDK files of around 40GB - it usually fails the first time around with the error above, so you clean the environment up and rerun and it will work.


However, we've got a few VMs with large VMDK files - one in particular was originally a 1.2TB RDM which we connected to the VM in virtual mode and cloned.


This one seems to fail pretty regularly and we cannot get it to convert.


The progress bar for ConvertTo-NcVhdx (just checking but is that exactly the same command as ConvertTo-NaVhdx) somtimes doesn't get past 0%, othertimes it bombs out at 3% and the furthest it got was 20% after which it bombed out after ten minutes with the same error as above.


Any ideas please or is there a limit of what the maximum size VMDK this can handle is?


I've stripped off the Out-Null statement at the end but there's no other output - I've also tried manually adding the -SkipUnmap command in case it wasn't being handled properly via the Splat variable but no difference there.


I've attached a redacted screenshot which also shows that the first disk (41GB) converts without issue but then the next throws a SIS clone error - is there any way to get more verbose output from this at all please?


Thanks in advance!



Have you tried converting the RDM LUN directly into a VHDX without the middle step? See example 4.


PS C:\Users\administrator.SMIS-RTP1> get-help -examples ConvertTo-NcVhdx


Convert a VMDK file, a fixed VHD file, or a Data ONTAP LUN into a VHDX file.

-------------- Example 1 --------------

C:\PS>ConvertTo-NaVhdx -SourceVhd F:\VHD\win2k8r2.vhd -DestinationVhdx F:\VHDX\win2k8r2.vhdx

Convert a VHD file to a VHDX file.


Mode LastWriteTime Length Name
---- ------------- ------ ----
-a--- 8/16/2012 3:05 PM 26847739904 win2k8r2.vhdx

-------------- Example 2 --------------

C:\PS>ConvertTo-NaVhdx -SourceVMDK X:\VMDK\Monolithic\win2k8r2.vmdk -DestinationVhdx X:\VHDX\win2k8r2.vhdx

Convert a VMDK file in a CIFS share into a VHDX file.


Mode LastWriteTime Length Name
---- ------------- ------ ----
-a--- 8/16/2012 3:00 PM 26847739904 win2k8r2.vhdx

-------------- Example 3 --------------

C:\PS>ConvertTo-NaVhdx -SourceVMDK /vol/vol2/cifs/VMDK/Monolithic/win2k8r2.vmdk -DestinationVhdx

Performs the same operation as Example 2, except it uses the direct path on the controller to the file. This is
useful if there is no CIFS share providing access to the VMDK file.


Name Type Size Created Modified Owner Group Perm Empty
---- ---- ---- ------- -------- ----- ----- ---- -----
/vol/vol2/cifs/VHDX/win2k8r2.vhdx file 25 GB 8/16/2012 8/16/2012 0 0 1077

-------------- Example 4 --------------

C:\PS>ConvertTo-NaVhdx -SourceLun /vol/vol2/luns/lun0 -DestinationVhdx F:\VHDX\fromLUN.vhdx

Convert the Data ONTAP LUN into a VHDX.


Mode LastWriteTime Length Name
---- ------------- ------ ----
-a--- 8/16/2012 3:38 PM 10775166976 fromLUN.vhdx


Hi, thanks for the reply.


We're currently trying to do a UAT of the migration via VMware clones so we can't work with the original RDM - I guess we could clone it to try that out.


I have found we have exactly the same problem with other base VMDK files though.


What is the maximum size that people have confirmed working with Mat4Shift please?


So far in testing on brand new NetApp hardware the ConvertTo-NcVhdx is failing with anything over 61GB - I'm working my way through the test machines to try and identify the tipping point, ie the largest size we can convert before it crashes out with the error shown.