Microsoft Virtualization Discussions

NetApp PowerShell Toolkit 4.0 (containing DataONTAP PowerShell Toolkit 3.3) Released!


Dear PowerShell community,

We are pleased to announce the availability of NetApp PowerShell Toolkit 4.0!

This exciting release unifies all three of NetApp’s PowerShell toolkits into a single package, with support for Data ONTAP, SANtricity, and the all-new Mars OS platform. We believe that combining the toolkits will provide a unified automation experience across NetApp’s storage platforms, and greatly simplify our PowerShell offerings with a single installation.
Release Notes:
Download location: (Please uninstall all existing versions of DataONTAP PowerShell Toolkit before installing this. Upgrade from DataONTAP PowerShell Toolkit 3.2.1 to NetApp PowerShell Toolkit 4.0 will not work)

New features:
•    Unified installation package, with each of the following as optional modules:
        -    Data ONTAP PowerShell Toolkit
        -    SANtricity PowerShell Toolkit
        -    Mars OS PowerShell Toolkit
•    Full API support for clustered Data ONTAP 8.3.1

Data ONTAP PowerShell Toolkit:
The NetApp PowerShell Toolkit 4.0  includes complete API coverage for clustered Data ONTAP 8.3.1  This includes 58 new cmdlets and 29 updates to existing cmdlets..

The following are new categories of cmdlets introduced in clustered Data ONTAP 8.3.1:
•    Security Key Manager – 7 cmdlets were added
•    Disk Encrypt – 4 cmdlets were added

The following categories have new cmdlets added:
•    Autosupport - 2 cmdlets
•    Cluster image - 2 cmdlets
•    Cluster - 5 cmdlets
•    Diagnosis - 2 cmdlets
•    Exports - 2 cmdlets
•    Igroup  - 1 cmdlet
•    License - 1 cmdlet
•    Lun - 3 cmdlets
•    Metrocluster - 1 cmdlet
•    Nameservice - 1 cmdlet
•    Net - 3 cmdlets
•    Quota - 5 cmdlets
•    Ses - 5 cmdlets
•    Snapmirror - 5 cmdlets
•    System - 2 cmdlets
•    Vscan - 1 cmdlet
•    Vserver - 5 cmdlets
•    VserverPeer - 1 cmdlet
•    Start-NaNdmpCopy and Invoke-NaNdmpCopy now support i18n
•    Virtual Machine conversion cmdlets are now supported on adaptive compression enabled volumes (works only on Data ONTAP 8.3.1 onwards)
•    New parameters were added to 26 cmdlets – check the ReleaseNotes section from Show-NcHelp for more details!
•    Get-NcCifsPreferredDomainController can now be directed to the cluster, in order to get preferred domain controllers for all vservers

Mars OS PowerShell Toolkit:
    The Mars OS PowerShell module contains 47 cmdlets that enable scripted administration of NetApp FlashRay all-flash storage systems. Typical use cases include storage provisioning and simple system configuration. Major features include:
•    Creating/modifying/mapping/unmapping/deleting LUNs
•    Creating/modifying/deleting initiator groups
•    Configuration of cluster and service processor networking
•    Monitoring shelf and SSD health

SANtricity PowerShell Toolkit:
The SANtricity PowerShell module contains over 100 cmdlets enabling the storage administration of NetApp E-Series storage systems and EF- Series all-flash arrays. The SANtricity PowerShell module leverages the NetApp SANtricity Web Services Proxy to provide a distributed management solution. Use cases range from simple volume or disk monitoring to complex environment setup and tear down.  By providing a rich object model, the Toolkit provides the PowerShell scripter with a wide range of insight into the storage objects. Major features include:
•    Creating/deleting volume groups and pools
•    Creating/deleting volumes
•    Creating/deleting mirror groups, snapshots, consistency groups, etc.
•    Host configuration
•    Health and performance monitoring


One Team



I downloaded this from the link provided (NetApp_PowerShell_Toolkit_4.0.0.msi).

I installed by running the .MSI.  The version looks like it is 3.2.1, not 3.3.  Is this correct?


PS C:\> get-natoolkitversion

Major Minor Build Revision
----- ----- ----- --------
3     2     1     68



I found that I had several installs scattered across my Windows 7 desktop causing some issues, which after removing them and then re-installing the new version everything worked as expected.


First, I went to Control Panel -> Programs and Features, then searched for "PowerShell" and removed everything NetApp PowerShell related...there were two entries, one for Data ONTAP PowerShell and another for the NetApp PowerShell Toolkit. 


Second, I checked all of the locations found in this Microsoft article and removed any instances of the DataONTAP modules found there (simply deleting the folder worked).


Then I reinstalled the toolkit using the MSI linked above.  The default install location is "C:\Program Files (x86)\NetApp\NetApp PowerShell Toolkit\Modules\", after the install, check your $Env:PSModulePath to make sure that folder has been added.  Then you can import the module as expected.


Hope that helps!



If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


I am running Windows 7 as well.

Your solution worked for me.  Thanks very much!

Probably should let others know they may need to uninstall and remove any "orphans".


Good suggestion Bill. I have updated the original post to add that all current DataONTAP PowerShell installations needs to be uninstalled before installing NetApp PowerShell Toolkit 40. - Aparajita


Where do I get the older PSTK versions?

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Only the latest DataONTAP PowerShell Toolkit versions are available for download from NetApp sites.


Only way to get an older version would be to contact someone who has that particular download hoarded away somewhere 🙂


Is there a current version of the c# Proxy for this release of the Toolkit?


Hi Team,


I tried every single step provided by Andrew but my system still imports the older Powershell Toolkit (3.3.0), not the actual one (4.1.0).

Please have a look at the attached Screenshot.

May I ask what may be the reason for this?


Kind regards,



EDIT: I am using Windows Server 2008 R2 x86 SP1 with PowerShell Version 5.0.10586.117 (Management Framework 5). Installing the .MSI with msiexec.exe as Windows Administrator did not work for me.


EDIT2: Layer 8 problem or problem sitting in front of computer screen... Data ONTAP POSHTK version 3.3 is already the correct one as highlighted in the thread topic: NetApp PowerShell Toolkit 4.0 (containing DataONTAP PowerShell Toolkit 3.3) Released!

Please apologize 😄


Hi Sascha,


What you're observing is the correct result, albeit probably unintuitive. The NetApp PowerShell Toolkit bundles two PowerShell modules - one for the Data ONTAP OS and the other for SANtricity OS. Each of the modules have their own versioning, which are different from the NetApp PowerShell Toolkit's version.


The Data ONTAP PowerShell Toolkit module available when you install the NetApp PowerShell Toolkit 4.1.0 is versioned 3.3.0. Hence you see version 3.3 being imported (which is the latest released version for Data ONTAP PSTK module).


Hope this helps,





The msi file will not continue to install because my version off powershell is not good. I tried to install on different computers with different versions of Powershell (v 3.0 and 4.0). Both under Windows 7 x64 but no luck. What else is missing to continue the installation?





Hi Bart,


This is strange - I just tried on Win7 x64 with PS 4.0 and 3.0 and was able to install on both. I tried with users which have Administrator privileges - though I did not run the installer with elevated privileges; are you using a Limited User? If you're, would it be possible the run the .msi as Administrator and check?


In the registry key HKLM\Software\Microsoft\Powershell\3, the INSTALL value should be set to 1 if PS 3.0 or above is installed on the system. Can you check whether it indeed is 1 on the machines you are attempting to install?


PowerShell 3.0 and .NET 3.5/4.0 should be enough to install the Toolkit.


Hope this helps,



"run as administrato"r did the trick. THX support!


I just stumbled across this tool today.  It is awesome!  Please keep up development as I find my career going more and more into devops.