Community maintenance is complete. Thank you for your patience!

Microsoft Virtualization Discussions

NetApp PowerShell Toolkit 4.3 released!

Shashanka

Dear PowerShell community,


We are glad to announce the release of NetApp PowerShell Toolkit version 4.3. This unified release has enhancements for both ONTAP and SANtricity modules.

 

ONTAP PowerShell Module:
The latest release adds upto 2050 cmdlets and provides complete API coverage for ONTAP 9.1 and is backward compatible with previous ONTAP releases.

 

SANtricity PowerShell Module:
The latest release adds upto 285 cmdlets and has the following enhancements: 

  • Provides ability for direct communication with E2800 storage array (SANtricity Web Services Proxy is not required)
  • Advanced Analytics (CPU Utilization, Interface stats, Controller stats)
  • ASUP support
  • Verbose and Windows Event logging support
  • Improved context help with examples
  • Improved error messages

Download the PowerShell Toolkit 4.3 from here


Regards,
NetApp PowerShell Toolkit Team

35 REPLIES 35

fmele88

is this thing free?

asulliva

Hello @fmele88,

 

Yes, the NetApp PowerShell Toolkit is free, though you must have a valid login to NetApp's MySupport site to download it.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

tuktuktuk

Does any else have a redirect loop on this?  Cant get to the page.

corey10112

We are getting an error as well. Multiple admins from our team have tried to download the content and we're met with errors on the landing page.

asulliva

Hello @corey10112,

 

Can you give more precise details on the error you're experiencing?  Are you encountering the redirect loop when visiting the ToolChest, the PSTK page, the download page?  I just went through the steps as I typed my response to get the links and it's working for me.  Perhaps try clearing the cache on your browser?

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

corey10112

Hello @asulliva,

 

I hadn't been able to get there via the link in the first post in this thread, it takes me to http://mysupport.netapp.com/tools/info/ECMLP2310788I.html?productID=61926 and gives me the following error:

 

Error 404--Not Found

From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1: 10.4.5 404 Not Found

The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.

If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address.

 

I was able to get it through the Toolchest though so thanks for mentioning that!

 

I went back to test from the first post using IE and Chrome. In Chrome and recieved the same error. I also tried clearing out temp files and cache for IE but it appears to be holding my session. Chrome at least promted me to login so I know it wasn't using and existing session. I'll test again with IE again, I just wanted to get you the error I was seeing prior to logging off and removing cached stuff.

 

Thanks

 

corey10112

Signed off and closed IE. Deleted all saved and cached data and then tried again. I was brought to the login prompt (as I should be) and when I logged in it took me to the same link with the same error. Toolchest and the PSTK page that you linked both work. It seems to be something linking from the original post here.

 

Thanks

asulliva

@corey10112,

 

I get similar behavior (a blank screen in Chrome) when using the links in the original post.  Perhaps @Shashanka can update the links.

 

Thank you for your help with troubleshooting!

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

StorageDude

I'm using Firefox 52.0.2 and I'm not having any problems.

tuktuktuk

I was eventually able to get in using IE, but Chrome and FF would kill the page saying there were too many redirects - However when i tested it just now i get 404.

Devo8604

Is there any way you guys can put this in the powershell gallery? Makes it super easy to update with powershellget when you guys release it...

asulliva

Hello @Devo8604,

 

Unfortunately not at this time.  The PSTK is hosted on the tool chest because of our EULA requirements.  I'm in agreement with you, I would like to see the PSTK, and really all of our SDKs, more easily available.

 

Thank you for your feedback!

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

drwoodberry

With the availability to run powershell on a Mac now, is there going to be a toolkit package to install on OS X?

asulliva

Hello @drwoodberry,

 

SolidFire has already released their PowerShell modules in a format compatible with Mac/Linux (including as a container).  ONTAP and E-Series (which combined are the NetApp PowerShell Toolkit package) are evalauating at this time.  I've been collecting support in this thread, please feel free to add a comment or kudo an existing post if you're interested.

 

Thank you!

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Tejaswini

THanks for the update Shashanka

AlexAtanasov

"Set-NcSis -EnableInlineDedupe $true" returns "WARNING: EnableInlineDedupe parameter available for Data ONTAP 9.0 and up." which is not true. Inline Dedupe is available since DataONTAP 8.3.2.

 

Is there any workaround for this?

asulliva

Even though the feature has existed since 8.3.2 the ZAPI wasn't added until 8.4 / 9.0 (ZAPI 1.100), which is what's causing the error.  You can work around this using Invoke-NcSsh.

 

Hope that helps.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Nick_Elliott

Looks like the version wasn't incremented in the version table

I had run the 4.3 installer, went to check that 4.3 was the the version in use and then uninstalled and reinstalled the toolkit using the 4.3 installer.

 

PS C:\Users\Nick Elliott> (gmo -l DataONTAP).Version

Major  Minor  Build  Revision
-----  -----  -----  --------
4      1      0      -1      



PS C:\Users\Nick Elliott> (gmo -l DataONTAP).Version

PS C:\Users\Nick Elliott> (gmo -l DataONTAP).Version

Major  Minor  Build  Revision
-----  -----  -----  --------
4      1      0      -1      

drwoodberry

I am getting the same thing when I just installed the latest toolkit.

 

I also ran "get-command -Module DataOntap).count" and it shows 2040.

 

Do you know if the version table is a bug?

asulliva

The toolkit and module versions will not necessarily match.  The toolkit has both the ONTAP and E-Series modules in it, if either of those modules are updated then the toolkit version is increased.  I believe PSTK 4.3 included a version increase for the E-Series module(s), but not the ONTAP module.

 

Hope that helps.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public