Microsoft Virtualization Discussions

New-NaVol Parameter

JAL

All,

Is there a way when creating a new volume via PowerShell using the cmdlet New-NaVol to turn off the default "Autogrow" setting? 

 

The defaut has this setting turned on and I'd like to be able to turn off this attribute within the script when creating new volumes.  I don't see it listed in the parameters.

 

Thanks for any help,

 

joe

1 ACCEPTED SOLUTION

asulliva

Hello @JAL,

 

Use the Set-NaVolAutosize cmdlet to disable the setting.

 

$volume = New-NaVol ...

$volume | Set-NcVolAutosize -Disabled

 

Hope that helps.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

2 REPLIES 2

asulliva

Hello @JAL,

 

Use the Set-NaVolAutosize cmdlet to disable the setting.

 

$volume = New-NaVol ...

$volume | Set-NcVolAutosize -Disabled

 

Hope that helps.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

JAL

Andrew,

Exactly what I was looking for.  If I would've spent a little more time, I may have found that cmdlet.

 

Thanks!

 

joe

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public