Microsoft Virtualization Discussions

PS toolkit 4.6 and invoke-ncssh failing winth Ontap 9.4

Hi guys

 

for some reasons  I use SSH commands in few cases instead of PS cmdlets in our automation scripts, not a WFA.

with Ontap 9.4 I receive the error

An established connection was aborted by the software in your host machine.

I found some hints in our community

so I'am using PS toolkit 4.6, installed putty 0.70 64bit and adjusted the permissions on that package, plink.exe is available

in the modules folder.

But still no success, on ontap9.0 everything is working, a ssh connection in putty to that 9.4 filer is working too.

I tried the cmdlet Invoke-NcSystemApi, but I'm not familarr with it and I receive the error 

Data at the root level is invalid.

 

Any ideas or suggestions regarding the onvoke-ncssh together with ontap 9.4 would be great

1 REPLY 1

Re: PS toolkit 4.6 and invoke-ncssh failing winth Ontap 9.4

You might want to look in the Windows Registry for this registry key:
   HKCU\SOFTWARE\SimonTatham\PuTTY64

If it doesn't exist, then that is part of the problem.  If this exists:

   HKCU\SOFTWARE\SimonTatham\PuTTY

you can try changing 'PuTTY' to 'PuTTY64', and see if it works.

 

You could also try the various suggestions in this thread:

https://community.netapp.com/t5/Microsoft-Virtualization-Discussions/Invoke-NcSsh-failing-with-ONTAP-9-3/m-p/137313

Cloud Volumes ONTAP
Review Banner
All Community Forums
Public