Microsoft Virtualization Discussions

Permissions Fail After PowerShell Toolkit Upgrade

TMADOCTHOMAS
257 Views

Hello,

I just upgraded from version 9.10.1.2111 to version 9.11.1.2208 of the PowerShell Toolkit. After the upgrade, all of my PowerShell scripts fail with the message shown below. Any ideas as to the cause? I reverted to the VMware snapshot I took before upgrading and verified I can run the exact same commands pre-upgrade without any errors.

 

Connect-NcController : The remote server returned an error: (401) Unauthorized.

FullyQualifiedErrorId : HttpConnectionFailed,DataONTAP.C.PowerShell.SDK.ConnectNcController

1 ACCEPTED SOLUTION

TMADOCTHOMAS
56 Views

In case anyone searches this post, the answer is here. One of our NetApp reps pointed me in this direction. Adding -ontapi to the Connect-NcController command worked!

 

https://community.netapp.com/t5/Microsoft-Virtualization-Discussions/Powershell-Toolkit-AD-Login-not-working/m-p/437841/highlight/true

View solution in original post

4 REPLIES 4

mbeattie
230 Views

Hi,

 

Are you using an LDAP account for authentication? I think there might be a bug with that in the PSTK version. I'll flag it with the developers

 

/Matt

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

TMADOCTHOMAS
208 Views

Hi @mbeattie , no it's just a normal Windows service account created just for PowerShell scripting. It has limited rights on each of the clusters.

TMADOCTHOMAS
116 Views

Does anyone else have insight into the cause of this issue? I will simply have to bypass this update if there's no solution, which I don't want to do.

TMADOCTHOMAS
57 Views

In case anyone searches this post, the answer is here. One of our NetApp reps pointed me in this direction. Adding -ontapi to the Connect-NcController command worked!

 

https://community.netapp.com/t5/Microsoft-Virtualization-Discussions/Powershell-Toolkit-AD-Login-not-working/m-p/437841/highlight/true

Public