Microsoft Virtualization Discussions

Remove-NAVol Confirm Switch

darobbins

When using the  remove-navol I always get a confirmation pop-up, even if I do not use the '-confirm'.  Is there a way around this?

1 ACCEPTED SOLUTION

ekashpureff

From an earlier post:

You can simply append -Confirm:$false to your Remove-NaVol command like so;

Set-NaVol $VOL -offline | Remove-NaVol -Confirm:$False

At your service,

Eugene Kashpureff

View solution in original post

3 REPLIES 3

ekashpureff

From an earlier post:

You can simply append -Confirm:$false to your Remove-NaVol command like so;

Set-NaVol $VOL -offline | Remove-NaVol -Confirm:$False

At your service,

Eugene Kashpureff

View solution in original post

darobbins

I was missing the colon, I will test tonight.  Thanks!

cknight

You can also use the ConfirmPreference setting:

http://communities.netapp.com/thread/9358

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public