Microsoft Virtualization Discussions

SCVMM 2012 R2 Does Not Recognize Available Space Utilizing SMI-S Agent 5.2 for SMB/CIFS Shares

NickHawkins

Hello Community -

 

I am having a small issue with the SMI-S Agent along with SCVMM 2012 R2. Here is a breif summary of this environment:

 

- NetApp 8020 Cluster running 8.2.1

- SMI-S Agent Version 5.2

- System Center Virtual Machine Manager 2012 R2

 

I am able to use the SMI-S provider in SCVMM to provision and allocate LUNs to Hyper-V hosts just fine. I can also provision SMB shares just fine, the problem is that SCVMM does not recognize any free space on the file server side:

 

2015-01-19_12-02-14.jpg

 

I can then provision share access to the Hyper-V hosts but SCVMM will not rate this share as a suitable place to store a VM of any size because it sees 0MB/GB of available capacity which is to small for any VM. 

 

Wondering if anyone else has ran into this problem in the community. Or if you have a working solution which versions of the software are you running?

 

Thanks,

 

-Nick

 

1 ACCEPTED SOLUTION

bingen

Nick, can you try this and see if it resolves the issue?

 

For each SVM
1. Turn off quotas

Ex:. cluster::> quota off -volume <volume_name> -vserver <vserver_name>


2. Add one default quota rule of type 'tree' on each volumes hosting SMB shares.

Note: If one already exists, this will fail, which is an expected behavior and fine.
Ex: cluster::> quota policy rule create -vserver <vserver_name> -policy-name default -volume <volume_name> -type tree -target ""

 

3. Turn on the quotas for that volume and restart SMI-S agent.

Ex: cluster::> quota on -volume <volume_name> -vserver <vserver_name>

{wait for job to complete}
Ex: cluster::> quota show -vserver <vserver_name>

 

Please let me know if that does the trick.

 

View solution in original post

4 REPLIES 4

bingen

Nick, can you try this and see if it resolves the issue?

 

For each SVM
1. Turn off quotas

Ex:. cluster::> quota off -volume <volume_name> -vserver <vserver_name>


2. Add one default quota rule of type 'tree' on each volumes hosting SMB shares.

Note: If one already exists, this will fail, which is an expected behavior and fine.
Ex: cluster::> quota policy rule create -vserver <vserver_name> -policy-name default -volume <volume_name> -type tree -target ""

 

3. Turn on the quotas for that volume and restart SMI-S agent.

Ex: cluster::> quota on -volume <volume_name> -vserver <vserver_name>

{wait for job to complete}
Ex: cluster::> quota show -vserver <vserver_name>

 

Please let me know if that does the trick.

 

View solution in original post

bingen

By the way, the share "size" that you define in VMM is implemented as a hard quota on a qtree in the NetApp cluster.

 

That's why I'm looking at this from the quota angle.

 

NickHawkins

Hi Bingen -

 

THank you for replying to this post. I was actually going to update this today that I have the issue resolved. My issue was that I had no default quota of the type tree on the volume I was using to provision SMB shares from SCVMM. Once SCVMM provisions a share it creates the qtree and share with a hard quata tied to the qtree. 

 

The solution you outlined was what I applied after working with NetApp support. 

 

Thank you for your help.

 

-Nick

BLANDATFAU

Having the same issue here for two shares. I tried the steps suggested as well as removing the netapp provider from vmm and adding it back. Anything other suggestions? And is there a way i can query this information with the smis command on the server hosting the smis agent?

Thanks!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public