Microsoft Virtualization Discussions

SMHV strange error, backups fail

Hello everyone

This is my first post to the communities since becoming a NetApp customer a little over a year ago.  I'm having a bit of a problem with SMHV running on a Server 2012 3-node cluster.  I'm running SnapManager for Hyper-V version and SnapDrive version 7.0.1.  SMHV seems somewhat touchy for me since I started using it, where things will be working fine, but then when Cluster Aware Updates run and reboot the nodes, one by one, SnapDrive starts to show LUNs as dedicated even though they are still shared and CSVs, and then SMHV starts to give me problems with failed backups.  The errors on SMHV differ, and this time the error is "An error occurred while creating Hyper-V backup.  StartIndex cannot be less than zero.  Parameter name: startIndex".  I searched high and low for this error, but couldn't find anything useful.  I tried removing my SM policies and datasets, removing the cluster and running the configuration wizard again, but nothing seems to make a difference.  The only way I can get a backup is if I create a new dataset containing only one or two VMs and run the backup against that.  That seems to indicate to me that the problem is with one or more of my VMs, but the error message (in both Snap Manager console and Windows event log) isn't very verbose, and I would hate to have to create a dataset and add one VM at a time until I get it to error out (I have 40 or so VMs).  There has to be a better way to troubleshoot it... any suggestions?

Thank you!



Re: SMHV strange error, backups fail

I'm having the same issue. Any news on how to fix this?

Re: SMHV strange error, backups fail

Hi Brandon

Nothing yet.  The only thing that I can think of is to possibly reboot each node, but I really don't want to shuffle around 40+ VMs to do that.  Is that a possibility for you?

Re: SMHV strange error, backups fail

I actually just got it working, but I'm not sure if it was just random (my experience with SMHV has shown that it behaves very randomly), or having to do with me moving the owner of the cluster. I tried moving the owner of the cluster resources to a different node and it still failed, then I moved it again and it succeeded. Also I noticed when I had the failures, it was complaining that it 'Could not find owner of VM [vmname]' on one of my VMs. I'm not sure if that's at all related or not.

I've noticed in the past with other errors I've gotten with SMHV that I could sometimes resolve them by draining one of my Hyper-V nodes and rebooting it and then moving the cluster resources onto that rebooted node. Sometimes that was all it took as opposed to rebooting every node.

Re: SMHV strange error, backups fail

Hi Brandon (and anyone else who read this thread but didn't have an answer)

I spoke with support on this and it turns out that this issue is caused by a bug in SMHV where the VM Snapshot path and Configuration file path (in HyperV) must contain a trailing backslash or this problem occurs.  Here is the bug report:

Pretty silly bug, but it caused me (and I'm sure others) many headaches.  After reading the bug report, and learning what caused this, everything made perfect sense.  I had previously done a HyperV storage migration to move some VMs between NetApp volumes, and when I did this, HyperV didn't put the trailing backslashes in the paths mentioned.  Immediately afterward, the backups started failing, and that is also why when I only selected certain VMs to backup the backup was successful

The resolution for me was to upgrade to the latest builds of SD and SMHV (7.0.2P2 and 2.0.2P1, respectively).  Those versions had the fix and after the upgrade, all VMs back up successfully.

Anyway, case closed, so I figured I'd share in case someone else has a similar problem and can't find anything on it.



View solution in original post

Cloud Volumes ONTAP
Review Banner
All Community Forums