Microsoft Virtualization Discussions

Setting timezone with Set-NcTime and Node Parameter Returns Success but Doesn't Change Timezone

mcgue
The timezone configuration setting is global to the cluster. However, the cmdlet documentation shows passing the -node parameter when configuring the timezone. When doing this it looks like a success; however, the timezone actually isn't changed. Removing the -node parameter allows the change to go through.
5 REPLIES 5

Aparajita

Hi,

 

Can you let me know which Data ONTAP version you're invoking Set-NcTime against?

 

I tried with 8.3.1 and observed an error is thrown and running the command in verbose mode clearly mentions `VERBOSE: Error: invalid argument "-node"`. We can certainly look at adding this information (about Node/Timezone incompatibility) in the documentation, but I'm curious to understand why it appears to pass in your setup while it clearly errors out in mine.

 

Thanks,

Aparajita

michaeljay

I am having a similar issue with cDOT 8.3.1P1 and the set-nctime cmdlet. I have tried various settings within the script but it will just not change the timezone:

 

Set-NcTime -Timezone America/New_York

 

Set-NcTime -node $node2 -Timezone "America/New_York"

 

Set-NcTime -Timezone "America/New_York"

 

$timeZone = "America/New_York"

Set-NcTime -Timezone $timeZone

 

Nothing I have tried has worked. I can set it in both CLI and Sysman, I can add time servers with the cmdlet:

 

$timeServer1 = "server_name"

New-NcNtpServer -ServerName $timeServer1

 

But the timezone just will not change. Is there a bug or am I not using this correctly?

 

 

michaeljay

Here is a new development. When I looked on the cluster and used the "time' command this is what I get:

 

rdonacle03::> time
  (timezone)
    Timezone: America/New_York

rdonacle03::>

 

But when I use the "date" command this is what i get:

 

rdonacle03::> date
Node      Date                     Time zone
--------- ------------------------ -------------------------
rdonacle03-01
          Tue May 17 06:16:35 2016 America/Los_Angeles
rdonacle03-02
          Tue May 17 06:16:35 2016 America/Los_Angeles
2 entries were displayed.

 

WTH? How can the cluster see 2 different timezones?

 

When I run this:

$timeZone = "America/New_York"

Set-NcTime -Timezone $timeZone

 

It appears to work but the Sysman display always showed New York and so did the "time" command. What is going on here?

michaeljay

Just to note, I was trying to go from New York to Los Angeles (back and forth) as a test. So when I used Los Angeles I could see the timezone change under the "date" command but the "time" command always showed New York and so did the Sysman display...

Aparajita

Definitely looks like a bug, possibly both in the PowerShell Toolkit and in Data ONTAP. Let me investigate further.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public