Microsoft Virtualization Discussions

cannot connect to filer


Hi guys,

What does this error mean?

Connect-NaController : The requested name is valid, but no data of the requested type was found

At line:1 char:21

+ Connect-NaController <<<<  filer03 -Credential root

    + CategoryInfo          : NotSpecified: (:) [Connect-NaController], SocketException

    + FullyQualifiedErrorId : System.Net.Sockets.SocketException,DataONTAP.PowerShell.SDK.ConnectNaController




I get that error when I pass in an invalid name for the controller after having made a successful HTTP(S) connection using passed-in credentials.  Is "filer03" a valid controller name?

The error is misleading, normally when I use an invalid controller name I get this:

Connect-NaController : No such host is known

But, under these circumstances, I get the same error Joel is showing:

First:   Connect-NaController -Name (valid controller name) -Credential (valid credential)  #  Establish a valid HTTP(s) connection to a controller.

Then:   Connect-NaControlelr -Name (INVALID controller name)    #  Try to establish a connection to a non-existing controller, you get the no data of the requested type is found error.

I'm fairily confiden teh error you are seeing is a generic .NET error related to DNS bubbling up to the top.


no go - thanks though

it's a domain user, not root

I've tried IP instead of hostname

tried http/s and RPC

I can access with those credentials from Putty



I'm wondering if you have a general issue reaching the controller.  SSH uses different network ports than RPC, HTTP and HTTPS.  Is there a firewall between you and the controller?  If so, can you try connecting from behind the firewall to rule it out?  It may be letting SSH through but blocking RPC, HTTP, and HTTPS.


that might be it


I'm curious if you ever resolved this.  Was the firewall your issue?


a lot of people are involved and I cannot get a clear answer - I just use Putty