Network and Storage Protocols

Access CIFS share using Local System account


I have a CIFS share on a FAS2552 which runs NetApp 8.2.2 Cluster-Mode.
A service needs to access this share running as Local System account.

I gave full rights on the share using DOMAIN\COMPUTERNAME$.
The service cannot access this share. When I run the service as DOMAIN\USER it works fine.
We'd really like the service to run under the local system account for various reasons.

We also tried connecting to the CIFS IP instead of the CIFS hostname but this didn't make a difference.
The time of the SAN is the same as the computer trying to access the share.

Does anybody know what might how to solve this?



where is the account?


Is the local service account created on the netapp filer or on the client you are accessing from?


You should be able to create a local account on the netapp filer and then from a windows client use a UNC path to browse to the CIFS share once appropriate permissions are provided and enter \\filername\cifsshare. it should then prompt for credentials at which point you enter the local account details you created on the filer. 


If that doesnt work and you are using a windows machine why dont you try to map a network drive instead and use alternative credentials.




Thanks for the reply but perhaps the issue is not clear enough.

The service running on the Windows server is domain joined and is trying to access the share using the LocalService account (DOMAIN\COMPUTERNAME$).

There is no user account associated with this service.

On the filer I allowed this DOMAIN\COMPUTERNAME$ full access to the share.

A service accessing a remote resource should use the UNC name and not a drive mapping (this is not supported).


Hi there


I have the same issue, did you ever get this resolved, if so how 


thanks in advance




Hi all,

we have exact the same problem.

Problem is only on cDot. On 7-Mode Systems the connection is possible.


Any solution regarding this problem?




Clustered mode doesn't support the use of local account for CIFS access until 9.1 - so with 8.2.2 this is not possible. The FAS25xx series can run 9.1, so our advice would be to upgrade if this is required functionality.


I thought the netapp local user account was supported starting with 9.0 not 9.1?


I stand corrected, it does indeed come in 9.0, but at this point, 9.1 is our long term support release, and most customers able to are running it instead of 9.0.