Network and Storage Protocols

Cannot mount NFS vol on a FAS3210 running Data Ontap 8.2.3P6


Here is the deal, we have an older FAS3210 that we thought would be a great repo for backups. NFS vols only go up to 50TB so I thought that we would create a 2nd volume to utilize all of the space. After creating the first volume I mounted it on my Linux backup server with no issues. I created the 2nd volume gave it the same permissions as the first volume in the exports and attempted to mount it. I added it to the fstab to ensure that it auto mounts on reboot and then ran a mount -a. It didn't error out however when I attempted to browse to the directory it hung and then timed out saying permission denied. This is odd since it's exactly the same as the first volume from a permission standpoint. 


Here are the mount options from the client: 172.x.x.x:/vol/NFS1 /mnt/veeam_repo02 nfs rsize=65536,wsize=65536,timeo=14,intr

From the client logs I see: 

kernel: nfs: server 172.x.x.x OK

nfs: server 172.x.x.x not responding, still trying


From the netapp I tried the following after using the "OnCommand System Manager" to create the volume and adjust the export settings

exportfs -io rw=172.x.x.x /vol/NFS1 and I see this node when I got to the rdfile /etc/rmtab but still i'm not able to mount this. I have tried mounting it from other servers and that is unsuccessful as well. The original mount is working great but for the life of me I can't figure out how to mount this second volume. Any ideas?


BTW i'm not that familiar with Netapp so please dumb down any suggestions for me. Thanks.




Hi there,


Adding an export to the /etc/exports file does not automatically export the filesystem. To report on which volumes are exported, type "exportfs" without any arguments and see if it is listed. If it is not, that means it isn't exported. 


This manual page outlines further use of the exportfs command -


Hope this helps!


Thanks Alex, 

So I tried to grant access to the server through the cli and when I attempt to connect from the host to the netapp, I see a whole chain of messages pop up through the netapp cli. It tells me CIFS: Error for Server..... which is odd as CIFS isn't enabled. I think it strying to talk to some DC's for authentication but it's returning STATUS_NO_LOGON_SERVERS. Of course none of this should be required for NFS so i'm not sure why it's doing this. From the host i'm seeing permission denied and from the netapp I see the following:


[USLGBNETAPP-A:NwkThd_00:warning]: NFS response to client 172.22.xx.xx for volume 0xe4d2b0c7(lgb_3210_3TB_vmNFS1) was slow, op was v3 access, 78 > 60 (in seconds)


I'm not sure why it would be timing out since the server is connecting directly to the storage network.