Network and Storage Protocols

Access denied to NFS share.


Hi i started to administer netapp server and i have two questions.

First question.

I have some problems to access CIFS Shares

fas 3020

Data ontap 7.3.4

shares :

ETC$     (/etc)    Remote Administration

vol3$    (/vol/vol3)    Remote Administration

root volume is vol0 

qtree vol0 : mixed style

i can access to \\filer\etc$

but i got an access error entering \\filer\vol3$

for both shares

BUILTIN\Administrators set to Full control.

and for vol3$ i tried to add my domain user with Full control rights.

The same error.

wcc -s winuser show that

NT membershitp




usermap.cfg is empty

I want to check  volume contents.

Please help.

One more problem.

i have some exports.

for specific IP a set read-only access. when i trying to mount and NFS export i did it without problem. But when i try to list directory content i got access denied.


/vol/vol0/soft : unix style

cifs export

/vol/vol0/soft  read-only access for my host.

i do

mount /mnt/soft filer:/vol/vol0/soft

until its ok

i do

cd /mnt/soft

i got access denied.

Only when i set a root access for this host i can access /mnt/soft.


i tride the same on my netapp simulator, i got no errors, but there is no connection to Active Directory.

Please help.




Problem resolved with CIFS shares. Using MMC i have set rights to shares (Security rights). NOw i can acces to cifs shares.

What about nfs exports (second question)?


One unsolicated comment: it is recommended to create a new volume for data access instead of using vol0. Vol0 should only contain the Data On Tap operating system files.

For the export, what is the result of "exportfs -q /vol/vol0/soft"?


Thank you for your answer.

about the root volume. Yes we are planning to separate on tap system files and our data files.

about the exports.

Sorry about the mistake. I tried to mount /vol/vol0/Soft and i can see content of this nfs share with ro rights.

But i have another NFS share /vol/vol0.

But there is situation described in my last post.

exportfs -q /vol/vol0

/vol/vol0       -sec=sys,(ruleid=1),ro=

exportfs -q /vol/vol0/soft

/vol/vol0/soft    -sec=sys,(ruleid=0),ro=,rw=,root=

im trying to mount to

What about ruleid?


Try 'exportfs -c /vol/vol0/soft ro'

Also try reading the exportfs manpage.  I assume you are mounting the share as root.  Also try turning on 'opiton nfs.mountd.trace'  on the CLI and watching the messages file.