Network and Storage Protocols

Backup Exec 2010 R2 NDMP backup on FAS2020 works, restore fails

I'm having some issues with a new Backup Exec 2010 R2 installation. I configured a NetApp FAS2020 as an NDMP device and want to backup files from the SAN to a tape drive connected to my backup server. I set up ndmpd according to this document ( and created a separate backup user (
Backup works perfectly, but restoring any file gives me an authentication failed error. The NDMP device has a "global" ndmp user configured in the BE device tab (tried this with the newly created ndmpd backup user and the netapp root) and I can also configure separate resource credentials in the BE restore job.
I have tried setting the same accounts for the "global" ndmp device and the restore credentials and have also tried setting different accounts for them.
NDMP debug level is at 5 and this is what shows up in /etc/messages. The session is closed immediately after access has been granted.
16:12:07 PST [Java_Thread:info]: ndmpdserver: ndmpd.access allowed for version = 4, sessionId = 51, from src ip =, dst ip = FAS2020-1/, src port = 50857, dst port = 10000
16:12:07 PST [Java_Thread:info]: Ndmpd51: ndmpd session closed successfully for version = 4, sessionId = 51, from src ip =, dst ip = FAS2020-1/, src port = 50857, dst port = 10000
Running wireshark on the backup server doesn't produce much. It shows a SYN -> SYN/ACK -> NDMP CONNECT_CLOSE Request from the backup server.
The Resource Credentials for the restore job behave very oddly. If I enter NDMP credentials and do "Test All" it fails. If I use my regular domain backup account, it is successful. There are no failed or successful logons in the NetApp ndmp log and tracing this check shows that it doesn't even connect to the SAN. This makes me think that this whole issue is more likely flaky BE behaviour rather than misconfiguration of the SAN.
Here is the options ndmp output:
FAS2020-1> options ndmp
ndmpd.access                 all
ndmpd.authtype               challenge
ndmpd.connectlog.enabled     on
ndmpd.enable                 on
ndmpd.ignore_ctime.enabled   off
ndmpd.offset_map.enable      on
ndmpd.password_length        16
ndmpd.preferred_interface    disable
ndmpd.tcpnodelay.enable      off

Thanks for your help!



Hi there!

I'm afraid I cannot help at the moent because I'm facing NDMP problem as well.

Could you be so kind and inform me how did you manage to connect tape library to FAS2020?

My configuration is: blade servers with FC cards, SAN swithes, IBM TS3100 FC library, FAS2020 filler with two FC controllers. The blade servers works using XenServer virtualisation platform and four paths to the filler.

I hope I made zoning corretly - tape drive to one filler's port 0b. But the filler doesn't discover tape drive.

I have red at NetApp KB that it's impossible to connect filler and tape (even through switch) on the same port.

Is it true? What is your experience?

Thank you for help.



First of all: I was able to solve this issue by starting from scratch and reconfiguring everything. Not sure what caused it in the first place.

To answer your question: My tape device is attached to a physical server, not the NetApp.


Hi Maciej,

I have red at NetApp KB that it's impossible to connect filler and tape (even through switch) on the same port.

What do you exactly mean by that? Connect some hosts & tape to the same port on the NetApp filer? This is not possible, indeed.

Any given port on the filer can act as:

a) target - for presenting storage to hosts acting as initiators

b) initiator - so the tape (target) sees the filer as a backup source (a kind of a host in fact)

The trouble is you can't configure a port to be a target & an initiator at the same time.




Just out of curiosity, what type of throughput are you seeing to your tape drive?  How much data are you able to back up per hour?



It's around 3GB/min.