Network and Storage Protocols

CIFS access issue


I created a new flexvol, /vol/test, and made a CIFS share test of it. I went through the CIFS setup,  since we don't have a Windows domain, I chose Workgroup - Unix Clear Text Passwords for Authentication. Workgroup name is WG, security style is NTFS. When I tried to add Access Control Entry for the share, I specify user Administrator, but I got error 'Unknown user/group Administrator'. The only thing it will take is root and everyone. But even after I gave everyone Full Control, I can't map the share \\filer\test from a Windows client, whose IP was actually specified as Administration Host. The error is 'The account is not authorized to log in from this station'. At this point, I tried to map the C$ share, same error. It used to work when I log on as WG\Administrator and I was able to copy over some firmware files for upgrade.

What did I do wrong? I have no domain, and only need Administrator user to access the share.



I figured it out. I should use Windows Workgroup authentication, not Unix.