Network and Storage Protocols

Fas2020 performance issue or not ?


Hi everybody.

i have a fas2020 in active/active mode with 12 sas 15k disk (1 spare, raid dp) mainly for san usage and 10 sata 7200 (1 spare, raid dp) for nas usage.

The fas2020 is connected with two 1gb network link in lacp mode on cisco 2690G.

I'm running data ontap version.

With differents volume on each type of disk, via cifs, from a computer connected on the same switch, i never had more than 50-55mb/s on reading from fas2020.

The sysstat -xsu 1 give me :see attached file

I tried with a direct connexion (twisted cable) between fas2020 and a computer, no more than 50Mo/s in reading from fas.

I ran reallocate each night on each volume.

I tried on a new volume, freshly reallocated, with on 4gb file, same throughput.

The network interfaces are not fully used.

Between two server on the same swith i copy file server to server at 110mb/s with a 1gb connexion, so the switch can manage more throughput that i have.

Is it normal to have no more than 50-55mb/s on a fas2020 ? I have 90-100mb/s on a small buffalo nas which cost 500€ !

Is there something wrong in my config ?

thanks for your answers




Depends on how you're testing. If just copying file, I get the same speed. I shared your feelings/disappointment when I first benchmarked this unit. Take a look Thread Link : 13413 I guess the point is this is entry level model and you shouldn't buy it for speed but reliability, scalability and usage as network storage for ex. virtualization. You can run more than just a few VMs on it and if you have 2 fillers you've got 2 LAN interfaces/FCP per filler so you can have total throughput ~250MB/s on reading and ~100MB/s on writing. I'm not so sure about database since I experience sequential log write issues, but live-testing will show the truth... Looking forward to hear your experiences.


one more element, my two aggregates are in "redirect" state.

All reallocate are aborted, no reallocate running.

How to reset the aggregate status to not "redirect" ?


I got the same problem with my FAS2020.  It's insanely slow, I am getting only 30MB/s from it.  My single desktop drives gets 100MB/s!!!  I even use 4GB/s FCP connection.


try to activate smbv2 options on filer :

options cifs.smb2.enable on

options cifs.smb2.client.enable on

retest with a windows vista or more, i get +/- 75mb/s now !!!

how many disk have you ?

you can use statit to know if your data are allocated on all disks (columns 'disk ut%')


Just saw your reply a year later..

I tried the smbv2.  It didn't make a difference for me.  Well, at least I tried.