Network and Storage Protocols

How to "delete" a share Folder ?


I need to delete a folder. I stop the share but in fact this action doesn´t delete a folder.  If I create a new share with the same name that the "stopped" share, the new folder contains all the attributes that the old folder (subfolders, permissions, etc).

Thanks !



I think you are going to have to try to ask your question in a way that is more understandable.

Try to include a bit of information about how it looks on the filer... the volume, qtree... cifs share and what commands you have used.  (the CLI is really very effective)

Try to get familiar with the system documentation on NOW.

You will probably get more help if you ask the question a bit more clearly.


Just create a new share one level up from the folder you want deleted, then connect to that share, delete your folder, and remove the share again (if you want)



Thank you Michael,

I understand that the problem would be solved for deleting the sobfolders. In this case this action is not possible. Please see attached file.



Removing (deleting) a cifs share surely does not remove any data below, within or above the share. Thank God!

This seems to be a Windows problem - not a NetApp problem. Se ha denegado el acceso. Access denied.

Try deleting that directories as the directory owner (or using an admin account).




Hi Peter,

I´ve trying to remove the folder with an admin account...




The point I tried to make at the very beginning is that your question is not clearly stated.  Simply by looking at the question, I was pretty sure that you did not understand some of the underlying terminologies and technologies.

1. Taking a CIFS share offline does not delete it.

2. Deleting a CIFS share (which you haven't done) doesn't delete the data, just the CIFS share (a pointer to a directory)

3. Have you actually listened to the suggestion that you create a share pointing to /vol/volStaging?  And then try to delete the directory (or as you call it, folder).

I think your life would probably be a lot easier with fewer shares anyway.  Your backup/staging script can surely find \\<netapp>\staging\$machine_name   instead of \\<netapp>\$machine_name.

The "directories" under /vol/volStaging  would probably be more flexible as qtrees.  In the end, you aren't going to get the help you need until you ask more specific questions and understand the terms and technology.


I understand about terminologies and technologies, but my english is as poor as your spanish.

I know that taking a CIFS share offline, does not delete it. I know that this process does not delete the data.

The problem is not related to define qtrees or shares... I need to remove the data and apparently I´ve a problem with access rights.



Please follow any one of the mothed.

Method1) If it is non-qtree, create a share to volume and delete the folder. (from windows/unix)

Method2) If it is a qtree, go to priv set advanced and use the #qtree delete <path> (from filer)