Network and Storage Protocols

How to reset ownership and permissions on files/folders on a CIFS share


Hi there!


I received an FAS2220 from a shuttered company site and I'm trying to get access to the data to see if it's relevant to the rest of the business.  Here's what I've done thus far:


- changed the root password via console

- changed the MGMT and VIF to a managable IP

- changed the shares to Everyone


This enabled me to see and manage both SPs.  So that gave me access to the full filer via onCommand.  Great!


The problem that I'm having is accessing the CIFS files and folders (NTFS-Windows). Using Windows Explorer, I've tried to take ownership of everything and it will run for a while, but then get's stuck with "Access is Denied" deeper in the structure.  I can navigate to the failed folder and take ownership and reset all of the permissions, but when I continue, it's get stuck on another one.  I've also tried takeown.exe with recursion, but it also gets stuck.


My goal is to force clean all permissions on all files and folders in the NetApp shares so that we can dig through the contents.  One-offing the failure points is way too time consuming.


Any advice that you can give me would be appreciated!






PRE-Admin -


You didn't mention the ONTAP version running.


I'd re-configure CIFS to join in with the domain as a fileserver OU unit.

Then use a custom GPO to propogate the permissions you want through the file system.

I hope this response has been helpful to you.

At your service,

Eugene E. Kashpureff, Sr.
Independent NetApp Consultant
Senior NetApp Instructor, Fast Lane US
(P.S. I appreciate 'kudos' on any helpful posts.)


Thanks for getting back to me!


onTap is v8.1.2RC2 7-Mode


The NetApp used to be a part of our domain, but I chose to remove the CIFS settings as I didn't know what would/could happen if I re-esablished it's domain connection.  It's currently in a workgroup, as I can't establish a domain connection to one of our sub-domains because of SRV record issues - the same sub-domain that our FAS2240-4 is in.  I'm trying to push Everyone to all of the files/folders for simplicity.  Also, I don't have administrative access to it's original domain, but I do the other sub-domain/forest.


If I could get it onto the sub-domain without the SRV errors (it is on a different subnet), then I could punch it through with a GPO.