ONTAP Discussions

Adding smaller disks


Hi, I had a raid group with 11 900gb drives, and i've added 5 600gb drives by mistake. Is there any way to replace those 600 gb drives with 900gb. Both parity disks are 900gb disks. I've tried replacing but the new 900gb disk became 600gb. Will it regain the free space if i replace the reset of the 600gb.  If this is not possible is there any free space loss? Thank you.



Hi LeoL,


Unfortunately, there is no way to replace the smaller 600 GB drives with the 900 GB drives without the bigger drives being right-sized to 600 GB. 


This is documented here:






Team NetApp

Team NetApp


Hi ttran,

Thank you very much for the quick reply and the link. I was actually looking at that article, and in the example it says


When an aggregate configured for RAID-DP protection is created, Data ONTAP assigns the role of dParity disk and regular parity disk to the largest and second largest disk in the RAID group.    

This is how the raid group was originally setup, with 11 900gb disks. Both parity disks are 900gb.


In this example, aggr2 has two 136-GB disks and one 68-GB disk. The 136-GB disks were used as the parity disks.

sys1> aggr status -r aggr2
Aggregate aggr2 (online, raid_dp) (block checksums)
  Plex /aggr2/plex0 (online, normal, active)
    RAID group /aggr2/plex0/rg0 (normal)

    RAID Disk Device HA SHELF BAY CHAN  Type  RPM   Used (MB/blks)      Phys (MB/blks)
    --------- ------ -- ----- --- ----- ----- ----- ------------------ ----------------
    dparity   0c.48  0c 3     0   FC:A  FCAL  10000 136000/278528000   137104/280790184
    parity    0c.50  0c 3     2   FC:A  FCAL  10000 136000/278528000   137104/280790184
    data      0a.28  0a 1     12  FC:A  FCAL  10000  68000/139264000    69536/142410400

 When another 136-GB disk is added to the aggregate, the disk is added as a data disk and is not restricted in size.

So if I fail the current 600gb disks that were added as the last 5 disks in the raid group and replace them with 900gb disks, that will not help? As mentioned before I've tried the disk replace command but that did not help.


Thank you again.