The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

ONTAP Discussions

Column width for cDOT statistics

NICKBARTON

Hello, 

 

I have searched and searched and haven't found if there is a way to increase column width for cli statistics output in cMode. Running 8.2.1. Specifically qos statistics output but I'm assuming the formating command would be the same for either. I'm hoping there is a way to do this from the command line if not I guess I will pursue pulling it via powershell and formatting the results. My specific issue is around cutting off the name of qos policy groups. The naming format I am dealing with has the unique information as the last three characters of the volume/policy name. 

 

Thanks, 

Nick 

7 REPLIES 7

ANDREW_WERCHOWIECKI

This is bugging the hell out of me too. Really keen on getting a configurable column width because if your SVM name and volume name exceed the grand total of 5 characters a "vol show" command ends up using FOUR lines of text to show information for ONE volume. Imagine if you had 100 volumes! It's awful on the eyes, and it's 2015 - we've all got widescreen monitors, let us use them!

Hi,

 

Netapp is in case of console resolution 30 years behind.

 

There is no way to change it. 

pavila

Have you tried using 'set -rows 0'

rustyb

This did the trick for me!!

 

Not sure why setting 'rows 0' removed the column width restriction, but it did the trick.

 

Thank you!

 

That only removes the "Press <space> to page down, <return> for next line, or 'q' to quit..." and mashes all the columns together.

 

Why not simply make the columns variable width, perhaps with an upper limit?

 

I mean look at this:

 

cluster::> disk show
Usable Disk Container Container
Disk Size Shelf Bay Type Type Name Owner
---------------- ---------- ----- --- ------- ----------- --------- --------

 

The disk column is 16 characters long, yet the Owner column is only 8 characters long. So NetApp decided to make sure their edge case of disk naming is covered (MCC disk names are much long than the typical 6 characters of "stack.shelf.bay") but decided that nobody would ever use a node hostname would never exceed 8 characters? Really? Really? Even NetBIOS allows up to 15 character hostnames in Windows environments. 

ekashpureff

 

Nick -

 

Have you tried 'set -showallfields true' ?


I hope this response has been helpful to you.

At your service,

Eugene E. Kashpureff, Sr.
Independent NetApp Consultant http://www.linkedin.com/in/eugenekashpureff
Senior NetApp Instructor, IT Learning Solutions http://sg.itls.asia/netapp
(P.S. I appreciate 'kudos' on any helpful posts.)

 

 

fschafhauser

Hi Nick, Hi Eugene,

 

thanks for your postings  Man Very Happy

 

I also searched to get rid of line feeds, too short columns at cDOT command line.

 

You can get csv like output after set this option:

set -showallfields true -showseparator ";"

 

Have fun!

Florian

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public