ONTAP Discussions

Data OntapEdge Unable to create ontap VM


Hello Everyone,


I'm trying to install ontap edge on my dell esxi 5.5 servers but i have a issue ..

When i start the wizard i introduce all parameters (ip, name, etc.) but when the process arrived at uploading dis to VM ********** the wizard stops with some errors ( while parsing ...).


Do you have an idea ?

Thanks a lot



What version of edge and what version/edition of ESX?  


I've seen problems deploying to 5.5 and newer updates of 5.1, but not the same errors you are seeing.  Those look more like the API calls are failing.  Could be a permissions issue with the account you are using, or maybe its managed by a vcenter you aren't connecting to, or maybe you are trying to run it against a free edition of ESX.


Rather than grabbing a screenshot, you can ssh to the dvadmin instance.  username/pw both netapp.  Then you can capture the text of the entire session.  Whatever the problem is, its already scrolled offscfreen.





the version of my esxi is 5.5 U2 and my ontap edge is version 822.121.

In fact, with ssh it's better 🙂


Below complete logs


Marked VM disks independent-persistent
Content-Length header value was wrong, fixed at /usr/share/perl5/LWP/Protocol/http.pm line 190.
[88] VmDiskDestroyErr: Failed to delete NIC:
SOAP Fault:
Fault string:
Error returned by expat parser: not well-formed (invalid token)

while parsing serialized value of type string
at line 7, column 108

while parsing property "label" of static type string

while parsing serialized DataObject of type vim.Description
at line 7, column 96

while parsing property "deviceInfo" of static type Description

while parsing serialized DataObject of type vim.vm.device.VirtualE1000
at line 7, column 49

while parsing property "device" of static type VirtualDevice

while parsing serialized DataObject of type vim.vm.device.VirtualDeviceSpec
at line 7, column 6

while parsing property "deviceChange" of static type ArrayOfVirtualDeviceConfigSpec

while parsing serialized DataObject of type vim.vm.ConfigSpec
at line 7, column 0

while parsing call information for method ReconfigVM_Task
at line 6, column 0

while parsing SOAP body
at line 5, column 3

while parsing SOAP envelope
at line 2, column 3

while parsing HTTP request for method reconfigure
on object of type vim.VirtualMachine
at line 1, column 0
Fault detail: InvalidRequestFault

Exiting wizard due to dvadmin command failure...


Thank you

Ok. What edition of ESX is this on? Enterprise? And is it managed by vCenter? If so, what version.

It looks like something goes wrong right around the time it starts adjusting setting on the vm. Then it can't clean up after itself. I suspect version/API incompatibilities, though permissions are still a candidate.


the version of esx is esxi 5.5 with the last update (2456374), enterprise version.

the version of vcenter is 5.5.0 2001466, and yes all esxi are managed by a vcenter


When you talk about permission, at which level of authentification are you thinking about ? between host and vcenter ? ... ?

Do you already had this issue ?



I've seen cases wheere an API call to change vm resources fails if the host is managed by vcenter, but the call is not placed through vcenter.  


I've also seen Edge deploy correctly but fail to boot on newer builds of esx.  


On the IMT, 5.5 is listed as supported but the updates are not listed.  So this could be an version compatability issue, or something peculiar about the values you are giving vm setup are exposing an issue in the script.





I already had try to deploy without vcenter informations, rename the datastore to avoid special caracters like (_)... i will to deploy on a host with esxi 5.1 version

I will check if there is a new version of data ontap edge ...


I ran an 8.2.2 7mode edge install against an ESX5.5GA with the VC6 RC, and it worked.  Don't have a 5.5U2 instance to try it against at the moment but I know 5.5GA is working with 8.2.2.




i've successfull has installed ontapedge 8.1.4P6 without any issues .. i really think that there is a problem with 8.2.2 version on esxi 5.5U2 ...

i will try to perfom an upgrade on 8.1.4P6 version to 8.2.2 and i will see if the vm starts after the upgrade