ONTAP Discussions

Fas2020+ ONTAP 8.0.X? Disk bad label version


So, to make a long story short, i have some disks that require me to be at ontap 8.0 or newer to use.  Apparently some of our vendors and/or engineers don't like to clear configurations/remove ownership before pulling disks out of systems, and as a result i'm stuck with several that have label versions that are too new for me to talk to.

I have several netapp systems at my disposal, A FAS270, 2020, 2050,and an R200, but apparently none of them support Ontap 8.0.X, which i need to upgrade to because i have disks that are label version 10, which requires 8.0 or newer.    Is there anything i can do apart from finding a FAS2040 or some such machine that DOES support ONTAP 8.0.X?  I have tried pretty much every method of label editing, disk unfailing, maintenance mode, advanced and diag priv modes, etc. that i have ever heard of, but no luck. 

Anyone who has any ideas (or a spare 2040, 3040, etc. lol) feel free to chime in! Any help is appreciated.


Re: Fas2020+ ONTAP 8.0.X? Disk bad label version

You said you'd tried every method of disk unfailing, so you might have tried this.  When I've seen the "bad label" message, I've been able to do a disk unfail -s in priv set advanced.


Re: Fas2020+ ONTAP 8.0.X? Disk bad label version

Hi Michael,

In my experience the only way to revert raid labels is to put them in a system thats running an ontap version thats compatible and then "revert" to the level of ontap you want to use them. Just like you said. 🙂


Re: Fas2020+ ONTAP 8.0.X? Disk bad label version

Yeah unfortuntately Bill I have tried that, no luck this time.  I have had that work in other situations though. 

Re: Fas2020+ ONTAP 8.0.X? Disk bad label version

I wonder if a proper configuration clear on the original filer would fix this, i'll have to do some experiments when/if i get a compatible system.  I would destroy any aggregates that the disks are members of, and remove their ownership before migrating to the older system.  Now I'm curious. 

Thanks for your input gents.

Re: Fas2020+ ONTAP 8.0.X? Disk bad label version

Since the writing of this post, we've been able to obtain a system running ONTAP 8.X, and as expected, we were able to plug the broken label disks into it and they showed up just fine.  A proper procedure was done before the disks were removed from the system, (transfer of ownership, removal of any foreign aggregates, zeroing, then removal of ownership) and they show up just fine in a 7.X system.  No need to revert the ONTAP version of the 8.X filer in order to get them to appear.   Hooray!

View solution in original post

Cloud Volumes ONTAP
Review Banner
All Community Forums