ONTAP Discussions

Individual storage space usage

trackstar
4,353 Views

Hello,

 

Is there a way to view individual disk space usage on the volume? 

 

We are on the following:

FAS2650 with 2 nodes.  Version NetApp Release 9.3P18.

 

Thanks,

TT

13 REPLIES 13

paul_stejskal
4,341 Views

No. You don't need to. ONTAP splits the raid stripes evenly across the aggregate. The only time it isn't even is if disks are added without a reallocate. https://kb.netapp.com/Advice_and_Troubleshooting/Data_Storage_Software/ONTAP_OS/What_are_the_best_practices_for_adding_disks_to_an_existing_aggregate%...

trackstar
4,338 Views

Sorry my question isn't clear.  I want to know how many GB of storage space JohnDoe uses on Volume1.

paul_stejskal
4,336 Views

Ah. File System Analytics on 9.8+ or quotas will give you what you want. There may be other methods, but those are the first two to come to mind.

trackstar
4,331 Views

I see.  We only have quota turned on for one volume.  Its been a while, but if I turned quota on for existing volumes the size would be enforced immediately and the processing consumption will go up?  Not sure if I want to turn on the quota just for this report.

 

EWILTS_SAS
4,304 Views

quota reporting and quota enforcement are related but you don't need quota enforcement for what you're trying to do.  We turn on quota reporting on EVERY volume as part of the volume creation process.  

quota policy rule create -vserver $vserver -policy-name $policyname -volume $volume -type user -target "" -qtree ""
quota on -vserver $vserver -volume $volume

Wait for the quotas to be calculated and then:
quota report $volume
either search for the user manually or add the options to report on only that user

for added enjoyment, go into diag mode and add -sort-by disk-used
this will sort the list so your biggest consumers are listed last.  It still surprises me that sort-by is only available in diag mode...



trackstar
4,212 Views

I just took a look again and all the production volumes have default quota on (Activate with the green dot on Quota Status on Volume  tab)

 

This commands works:

volume quota report -vserver vs0 -volume vol1 -quota-type user

 

But when I added the username in it failed with Error: "quota-target" is an invalid value for field "-index <integer>"

 

volume quota report -vserver vs0 -volume vol1 -quota-type user -quota-target john

 I am referencing this link:

https://docs.netapp.com/us-en/ontap-cli-98/volume-quota-report.html#examples

paul_stejskal
4,210 Views
What was the error message?

trackstar
4,209 Views

Error: "quota-target" is an invalid value for field "-index <integer>"

paul_stejskal
4,208 Views
Sounds like a typo or you're missing a field -index in your command.

trackstar
4,207 Views

You are quick!  Yes I  was missing "-" before the quota target command.

 

I am using putty.  Lets say I run this command below and it shows your typical result (need to press enter or space bar to view next entry/page).  Is there anyway to write this into a file?

 

volume quota report -vserver vs0 -volume vol1 -quota-type user

trackstar
4,194 Views

I am aware of the logging.  My question wasn't clear.

I meant of writing a csv file output but I guess it won't be allowed under the user agreement.  Thanks for your help though.  Appreciated it!

TT

Public